Mir

Valgrind errors in NesterServer.* cause subsequent tests (ServerDisconnect, ServerStartup, UnresponsiveClient) to fail

Bug #1612012 reported by Daniel van Vugt on 2016-08-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Confirmed
Medium
Alexandros Frantzis
0.24
Fix Released
Medium
Alexandros Frantzis
mir (Ubuntu)
Medium
Unassigned

Bug Description

Tests always fail together: ServerDisconnect, ServerStartup, UnresponsiveClient

17:27:52 9: [ FAILED ] 5 tests, listed below:
17:27:52 9: [ FAILED ] ServerDisconnect.is_detected_by_client
17:27:52 9: [ FAILED ] ServerDisconnect.doesnt_stop_client_calling_API_functions
17:27:52 9: [ FAILED ] ServerStartup.creates_endpoint_on_filesystem
17:27:52 9: [ FAILED ] ServerStartup.after_server_sigkilled_can_start_new_instance
17:27:52 9: [ FAILED ] UnresponsiveClient.does_not_hang_server

[https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=vivid+overlay/1772/consoleFull]

This is happening regularly in CI. These failures occur together.

Related branches

Daniel van Vugt (vanvugt) wrote :

This is happening too often. Bumping importance.

Changed in mir:
importance: Medium → High
Alexandros Frantzis (afrantzis) wrote :

The failures are caused by valgrind errors found in previous tests. The tests fail together because the all fork processes which, when exiting, fail due to the pending valgrind errors.

summary: - Tests always fail together: ServerDisconnect, ServerStartup,
- UnresponsiveClient
+ Valgrind errors in NesterServer.* cause subsequent test
+ (ServerDisconnect, ServerStartup, UnresponsiveClient) to fail
summary: - Valgrind errors in NesterServer.* cause subsequent test
+ Valgrind errors in NesterServer.* cause subsequent tests
(ServerDisconnect, ServerStartup, UnresponsiveClient) to fail
Changed in mir:
assignee: nobody → Alexandros Frantzis (afrantzis)
Changed in mir:
milestone: none → 0.25.0
mir-ci-bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.25.0

Changed in mir:
status: New → Fix Committed
Daniel van Vugt (vanvugt) wrote :
Changed in mir (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.24 at revision 3640, scheduled for release in Mir 0.24.1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.24.1+16.10.20160928-0ubuntu1

---------------
mir (0.24.1+16.10.20160928-0ubuntu1) yakkety; urgency=medium

  * New upstream release 0.24.1 (https://launchpad.net/mir/+milestone/0.24.1)
    - ABI summary:
      . All ABI numbers remain unchanged.
      . mircommon ABI at 6, but now including a symbol misplaced in 0.24.0
    - Bugs fixed:
      . mirserver ignored further keymap configuration changes after a keyboard
        is configured (LP: #1626435)
      . fix for libmircommon.so.6 ABI break: version stanza of
        mir::dispatch::ReadableFd* moved to newer version (LP: #1617865)
      . clang builds fail (again) (LP: #1609612)
      . Valgrind errors in NesterServer.* cause subsequent tests
        (ServerDisconnect, ServerStartup, UnresponsiveClient) to fail
        (LP: #1612012)
      . Break potentially infinite loop in search for next session to focus
        (LP: #1625401)

 -- Andreas Pokorny <email address hidden> Wed, 28 Sep 2016 12:09:49 +0000

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Daniel van Vugt (vanvugt) wrote :

Indeed the cause is again valgrind errors in NestedServer tests. But should we be reusing the same bug? Just search for "==12777==":

20:13:30 9: [----------] 25 tests from NestedServer
20:13:30 9: [ RUN ] NestedServer.nested_platform_connects_and_disconnects
20:13:31 9: [2016-11-02 20:13:31.685261] mirserver: Starting
20:13:31 9: [2016-11-02 20:13:31.689667] mirserver: Selected driver: mir:stub-graphics (version 0.25.0)
20:13:31 9: [2016-11-02 20:13:31.733003] mirserver: Using software cursor
20:13:32 9: [2016-11-02 20:13:32.118804] mirserver: Selected input driver: mir:stub-input (version: 0.25.0)
20:13:32 9: [2016-11-02 20:13:32.128108] mirserver: Mir version 0.25.0
20:13:32 9: [2016-11-02 20:13:32.211391] mirserver: Starting
20:13:34 9: [2016-11-02 20:13:34.070068] mirserver: Using nested cursor
20:13:34 9: ==12777== Thread 9:
20:13:34 9: ==12777== Invalid read of size 4
20:13:34 9: ==12777== at 0x540688F: MirWaitHandle::wait_for_all()::$_0::operator()() const (mir_wait_handle.cpp:53)
20:13:34 9: ==12777== by 0x5406401: void std::condition_variable::wait<MirWaitHandle::wait_for_all()::$_0>(std::unique_lock<std::mutex>&, MirWaitHandle::wait_for_all()::$_0) (condition_variable:98)
20:13:34 9: ==12777== by 0x5406376: MirWaitHandle::wait_for_all() (mir_wait_handle.cpp:53)
20:13:34 9: ==12777== by 0x54774D9: mir_connection_create_buffer_stream_sync (mir_buffer_stream_api.cpp:76)
20:13:34 9: ==12777== by 0x517576D: (anonymous namespace)::MirClientHostSurface::set_cursor_image(mir::graphics::CursorImage const&) (mir_client_host_connection.cpp:168)
20:13:34 9: ==12777== by 0x5175D95: mir::graphics::nested::MirClientHostConnection::set_cursor_image(mir::graphics::CursorImage const&) (mir_client_host_connection.cpp:430)
....

Changed in mir:
milestone: 0.25.0 → 0.26.0
Changed in mir:
milestone: 0.26.0 → none
Changed in mir:
importance: High → Medium
Michał Sawicz (saviq) wrote :

Syncing task from Mir.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers