Mir

[ FAILED ] ClientLogging.reports_performance (Value of: render)

Bug #1584605 reported by Daniel van Vugt on 2016-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
0.23
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Undecided
Unassigned

Bug Description

10:32:32 9: [ RUN ] ClientLogging.reports_performance
10:32:32 9: [2016-05-20 10:32:32.094437] mirserver: Starting
10:32:32 9: [2016-05-20 10:32:32.101512] mirserver: Selected driver: dummy (version 0.23.0)
10:32:32 9: [2016-05-20 10:32:32.146166] mirserver: Initial display configuration:
10:32:32 9: [2016-05-20 10:32:32.146653] mirserver: 1.1: VGA 0.0" 0x0mm
10:32:32 9: [2016-05-20 10:32:32.146953] mirserver: Current mode 1600x1600 60.00Hz
10:32:32 9: [2016-05-20 10:32:32.147272] mirserver: Preferred mode 1600x1600 60.00Hz
10:32:32 9: [2016-05-20 10:32:32.147527] mirserver: Logical position +0+0
10:32:32 9: [2016-05-20 10:32:32.151831] mirserver: Using software cursor
10:32:32 9: [2016-05-20 10:32:32.188313] mirserver: Selected input driver: mir:stub-input (version: 0.23.0)
10:32:32 9: [2016-05-20 10:32:32.190056] mirserver: Mir version 0.23.0
10:32:43 9: /��BUILDDIR��/mir-0.23.0+vivid1136bzr3514/tests/acceptance-tests/test_client_logging.cpp:114: Failure
10:32:46 9: Value of: render
10:32:47 9: Expected: is < 100
10:32:47 9: Actual: 696.43 (of type float)
10:32:47 9: /��BUILDDIR��/mir-0.23.0+vivid1136bzr3514/tests/acceptance-tests/test_client_logging.cpp:115: Failure
10:32:47 9: Value of: lag
10:32:47 9: Expected: is > 50
10:32:47 9: Actual: 0 (of type float)
10:32:47 9: /��BUILDDIR��/mir-0.23.0+vivid1136bzr3514/tests/acceptance-tests/test_client_logging.cpp:117: Failure
10:32:47 9: Value of: Test::HasFailure()
10:32:47 9: Actual: true
10:32:47 9: Expected: false
10:32:47 9: Log line = {[StringStreamLogger] perf: Rumpelstiltskin: 1.41 FPS, render time 696.43ms, buffer lag 0.00ms (3 buffers)}
10:32:47 9: [ FAILED ] ClientLogging.reports_performance (8692 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=vivid+overlay/1107/consoleFull

Related branches

Daniel van Vugt (vanvugt) wrote :

If CI can only achieve 1.4 FPS then CI needs fixing. And by fixing I mean we need to find better/more hardware if we are to continue to grow our automated performance testing beyond a single krillin phone in future.

Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
description: updated
Changed in mir:
milestone: none → 0.24.0
status: New → In Progress
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision 3518, scheduled for release in mir, milestone 0.24.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.23 at revision 3500, scheduled for release in Mir 0.23.0.

'Invalid' for the Ubuntu project as the bug never existed there.

Changed in mir:
importance: Undecided → Medium
Changed in mir (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.23.0+16.10.20160602.1-0ubuntu1

---------------
mir (0.23.0+16.10.20160602.1-0ubuntu1) yakkety; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.23.0 (https://launchpad.net/mir/+milestone/0.23.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 40
      . mircommon ABI bumped at 6
      . mirplatform ABI unchanged at 11
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 9
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 5
    - Enhancements:
      . Enable internal usage of more flexible graphics buffer submission,
        precursing client API additions.
    - Bug fixes:
      . Potential NBS performance loss after resize (LP: #1579076)
      . Performance loss with NBS and overlays on (LP: #1578159)
      . Mir crashes with useless backtrace when mg::Platform methods throw
        (LP: #1553549)
      . Virtual output is not removed when screencast client disappears
        (LP: #1573572)
      . Can't VT switch from mir_demo_server (any more) (LP: #1576260)
      . mir_demo_server(_minimal): Window movement/resizing stops responding
        when the cursor leaves the surface, and can lead to windows 1px wide
        and unrecoverable. (LP: #1447886)
      . Virtual display output configuration is set to LVDS (LP: #1573782)
      . Mir-on-X11 doesn't pass Alt+primary button drag to Mir (LP: #1575765)
      . Mir-on-X11 breaks mir_proving_server resize logic (LP: #1575192)
      . Resizing can crash mir_demo_server (LP: #1575211)
      . [regression] Cursor stops at phantom edge on M10 and N7 (LP: #1580774)
      . [regression] MIR_CLIENT_PERF_REPORT is showing bogus render times and
        buffer lag (LP: #1581368)
      . Test failures in ClientLogging.reports_performance due to the above
        fix. (LP: #1583970, LP: #1584603, LP: #1584605)
      . Do not throw when creating some objects under HWC 1.5 (LP: #1583086)
      . Correct black frame issue under Xmir (LP: #1584784)

  [ Tarmac, Kevin DuBois <email address hidden>, Daniel van Vugt <email address hidden>, Andreas Pokorny <email address hidden>, Alberto Aguirre ]
  * 0.23.0 Mir release

 -- Kevin DuBois <email address hidden> Thu, 02 Jun 2016 13:18:03 +0000

Changed in mir (Ubuntu):
status: Invalid → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers