Mir

[testsfail] ClientLogging.reports_performance [Value of: lag]

Bug #1583970 reported by Alan Griffiths on 2016-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
0.23
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Undecided
Unassigned

Bug Description

Doesn't seem to be quite the same thing as lp:1563148 (although probably related to the same underlying dependence on realtime).

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial/1095/consoleFull

17:18:25 13: [ RUN ] ClientLogging.reports_performance
17:18:25 13: [2016-05-19 17:18:25.480624] mirserver: Starting
17:18:25 13: [2016-05-19 17:18:25.483906] mirserver: Selected driver: dummy (version 0.23.0)
17:18:25 13: [2016-05-19 17:18:25.517901] mirserver: Using software cursor
17:18:25 13: [2016-05-19 17:18:25.523291] mirserver: Initial display configuration:
17:18:25 13: [2016-05-19 17:18:25.523635] mirserver: 1.1: VGA 0.0" 0x0mm
17:18:25 13: [2016-05-19 17:18:25.523889] mirserver: Current mode 1600x1600 60.00Hz
17:18:25 13: [2016-05-19 17:18:25.524090] mirserver: Preferred mode 1600x1600 60.00Hz
17:18:25 13: [2016-05-19 17:18:25.524267] mirserver: Logical position +0+0
17:18:25 13: [2016-05-19 17:18:25.551303] mirserver: Selected input driver: mir:stub-input (version: 0.23.0)
17:18:25 13: [2016-05-19 17:18:25.552840] mirserver: Mir version 0.23.0
17:18:29 13: /��BUILDDIR��/mir-0.23.0+xenial1124bzr3512/tests/acceptance-tests/test_client_logging.cpp:115: Failure
17:18:29 13: Value of: lag
17:18:29 13: Expected: is > 50
17:18:29 13: Actual: 20.89 (of type float)
17:18:29 13: /��BUILDDIR��/mir-0.23.0+xenial1124bzr3512/tests/acceptance-tests/test_client_logging.cpp:117: Failure
17:18:29 13: Value of: Test::HasFailure()
17:18:29 13: Actual: true
17:18:29 13: Expected: false
17:18:29 13: Log line = {[StringStreamLogger] perf: Rumpelstiltskin: 8.56 FPS, render time 3.67ms, buffer lag 20.89ms (3 buffers)}
17:18:29 13: [ FAILED ] ClientLogging.reports_performance (4524 ms)

Related branches

Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
milestone: none → 0.24.0
summary: - [testsfail] ClientLogging.reports_performance
+ [testsfail] ClientLogging.reports_performance [Value of: lag]
Changed in mir:
status: New → In Progress
tags: added: testsfail
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.24.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.23 at revision 3500, scheduled for release in Mir 0.23.0.

'Invalid' for the Ubuntu project as the bug never existed there.

Changed in mir:
importance: Undecided → Medium
Changed in mir (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.23.0+16.10.20160602.1-0ubuntu1

---------------
mir (0.23.0+16.10.20160602.1-0ubuntu1) yakkety; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.23.0 (https://launchpad.net/mir/+milestone/0.23.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 40
      . mircommon ABI bumped at 6
      . mirplatform ABI unchanged at 11
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 9
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 5
    - Enhancements:
      . Enable internal usage of more flexible graphics buffer submission,
        precursing client API additions.
    - Bug fixes:
      . Potential NBS performance loss after resize (LP: #1579076)
      . Performance loss with NBS and overlays on (LP: #1578159)
      . Mir crashes with useless backtrace when mg::Platform methods throw
        (LP: #1553549)
      . Virtual output is not removed when screencast client disappears
        (LP: #1573572)
      . Can't VT switch from mir_demo_server (any more) (LP: #1576260)
      . mir_demo_server(_minimal): Window movement/resizing stops responding
        when the cursor leaves the surface, and can lead to windows 1px wide
        and unrecoverable. (LP: #1447886)
      . Virtual display output configuration is set to LVDS (LP: #1573782)
      . Mir-on-X11 doesn't pass Alt+primary button drag to Mir (LP: #1575765)
      . Mir-on-X11 breaks mir_proving_server resize logic (LP: #1575192)
      . Resizing can crash mir_demo_server (LP: #1575211)
      . [regression] Cursor stops at phantom edge on M10 and N7 (LP: #1580774)
      . [regression] MIR_CLIENT_PERF_REPORT is showing bogus render times and
        buffer lag (LP: #1581368)
      . Test failures in ClientLogging.reports_performance due to the above
        fix. (LP: #1583970, LP: #1584603, LP: #1584605)
      . Do not throw when creating some objects under HWC 1.5 (LP: #1583086)
      . Correct black frame issue under Xmir (LP: #1584784)

  [ Tarmac, Kevin DuBois <email address hidden>, Daniel van Vugt <email address hidden>, Andreas Pokorny <email address hidden>, Alberto Aguirre ]
  * 0.23.0 Mir release

 -- Kevin DuBois <email address hidden> Thu, 02 Jun 2016 13:18:03 +0000

Changed in mir (Ubuntu):
status: Invalid → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers