Mir

Can't VT switch from mir_demo_server (any more)

Bug #1576260 reported by Robert Ancell on 2016-04-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Robert Ancell
mir (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

I can't VT switch from mir_demo_server. This turns out to be an issue that occurred in 16.04 where /dev/console no longer works with VT switching. Using /dev/tty0 work. See bug 1566073 for associated change in LightDM.

Tags: vt Edit Tag help

Related branches

Alan Griffiths (alan-griffiths) wrote :

I've not encountered this problem - VT switching works for me (on desktop and a couple of Thinkpad laptops).

Is this specific to certain devices?

Robert Ancell (robert-ancell) wrote :

My guess it that it is video driver / hardware dependent, but I wasn't able to exactly pinpoint where the issue is. I couldn't find any documentation as to which device is the correct one to use, but /dev/tty0 seems to be used by larger projects (logind, GDM) and thus is probably better tested.

I'm using a Toshiba P50W with Intel Haswell-ULT graphics and running 16.04 LTS.

Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.23.0

Changed in mir:
status: New → Fix Committed
tags: added: vt
Changed in mir:
milestone: none → 0.23.0
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
summary: - Can't VT switch from mir_demo_server
+ Can't VT switch from mir_demo_server (any more)
Changed in mir:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.23.0+16.10.20160602.1-0ubuntu1

---------------
mir (0.23.0+16.10.20160602.1-0ubuntu1) yakkety; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.23.0 (https://launchpad.net/mir/+milestone/0.23.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 40
      . mircommon ABI bumped at 6
      . mirplatform ABI unchanged at 11
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 9
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 5
    - Enhancements:
      . Enable internal usage of more flexible graphics buffer submission,
        precursing client API additions.
    - Bug fixes:
      . Potential NBS performance loss after resize (LP: #1579076)
      . Performance loss with NBS and overlays on (LP: #1578159)
      . Mir crashes with useless backtrace when mg::Platform methods throw
        (LP: #1553549)
      . Virtual output is not removed when screencast client disappears
        (LP: #1573572)
      . Can't VT switch from mir_demo_server (any more) (LP: #1576260)
      . mir_demo_server(_minimal): Window movement/resizing stops responding
        when the cursor leaves the surface, and can lead to windows 1px wide
        and unrecoverable. (LP: #1447886)
      . Virtual display output configuration is set to LVDS (LP: #1573782)
      . Mir-on-X11 doesn't pass Alt+primary button drag to Mir (LP: #1575765)
      . Mir-on-X11 breaks mir_proving_server resize logic (LP: #1575192)
      . Resizing can crash mir_demo_server (LP: #1575211)
      . [regression] Cursor stops at phantom edge on M10 and N7 (LP: #1580774)
      . [regression] MIR_CLIENT_PERF_REPORT is showing bogus render times and
        buffer lag (LP: #1581368)
      . Test failures in ClientLogging.reports_performance due to the above
        fix. (LP: #1583970, LP: #1584603, LP: #1584605)
      . Do not throw when creating some objects under HWC 1.5 (LP: #1583086)
      . Correct black frame issue under Xmir (LP: #1584784)

  [ Tarmac, Kevin DuBois <email address hidden>, Daniel van Vugt <email address hidden>, Andreas Pokorny <email address hidden>, Alberto Aguirre ]
  * 0.23.0 Mir release

 -- Kevin DuBois <email address hidden> Thu, 02 Jun 2016 13:18:03 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers