Mir

Mir-on-X11 doesn't pass Alt+primary button drag to Mir

Bug #1575765 reported by Alan Griffiths on 2016-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Cemil Azizoglu
mir (Ubuntu)
Undecided
Unassigned

Bug Description

$ mir_demo_server --launch mir_demo_client_egltriangle

Expected: "Alt+primary drag" on the client surface drags the spinning triangle.
Observed: "Alt+primary drag" on the client surface drags the whole Mir-on-X window.

Related branches

Cemil Azizoglu (cemil-azizoglu) wrote :

Ok I guess I'll need to implement pointer grabbing.

Changed in mir:
assignee: nobody → Cemil Azizoglu (cemil-azizoglu)
status: New → In Progress
importance: Undecided → Medium
milestone: none → 0.23.0
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision 3487, scheduled for release in mir, milestone 0.23.0

Changed in mir:
status: In Progress → Fix Committed
summary: - Mir-on-X11 doesn't pass Alt+primary drag to Mir
+ Mir-on-X11 doesn't pass Alt+button drag to Mir
tags: added: mesa-x11
summary: - Mir-on-X11 doesn't pass Alt+button drag to Mir
+ Mir-on-X11 doesn't pass Alt+primary button drag to Mir
Changed in mir:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.23.0+16.10.20160602.1-0ubuntu1

---------------
mir (0.23.0+16.10.20160602.1-0ubuntu1) yakkety; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.23.0 (https://launchpad.net/mir/+milestone/0.23.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 40
      . mircommon ABI bumped at 6
      . mirplatform ABI unchanged at 11
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 9
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 5
    - Enhancements:
      . Enable internal usage of more flexible graphics buffer submission,
        precursing client API additions.
    - Bug fixes:
      . Potential NBS performance loss after resize (LP: #1579076)
      . Performance loss with NBS and overlays on (LP: #1578159)
      . Mir crashes with useless backtrace when mg::Platform methods throw
        (LP: #1553549)
      . Virtual output is not removed when screencast client disappears
        (LP: #1573572)
      . Can't VT switch from mir_demo_server (any more) (LP: #1576260)
      . mir_demo_server(_minimal): Window movement/resizing stops responding
        when the cursor leaves the surface, and can lead to windows 1px wide
        and unrecoverable. (LP: #1447886)
      . Virtual display output configuration is set to LVDS (LP: #1573782)
      . Mir-on-X11 doesn't pass Alt+primary button drag to Mir (LP: #1575765)
      . Mir-on-X11 breaks mir_proving_server resize logic (LP: #1575192)
      . Resizing can crash mir_demo_server (LP: #1575211)
      . [regression] Cursor stops at phantom edge on M10 and N7 (LP: #1580774)
      . [regression] MIR_CLIENT_PERF_REPORT is showing bogus render times and
        buffer lag (LP: #1581368)
      . Test failures in ClientLogging.reports_performance due to the above
        fix. (LP: #1583970, LP: #1584603, LP: #1584605)
      . Do not throw when creating some objects under HWC 1.5 (LP: #1583086)
      . Correct black frame issue under Xmir (LP: #1584784)

  [ Tarmac, Kevin DuBois <email address hidden>, Daniel van Vugt <email address hidden>, Andreas Pokorny <email address hidden>, Alberto Aguirre ]
  * 0.23.0 Mir release

 -- Kevin DuBois <email address hidden> Thu, 02 Jun 2016 13:18:03 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers