Mir

[testsfail] ClientLatency.throttled_input_rate_yields_lower_latency

Bug #1554572 reported by Alan Griffiths on 2016-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Undecided
Unassigned

Bug Description

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=vivid+overlay/384/consoleFull

15:05:36 10: [ RUN ] ClientLatency.throttled_input_rate_yields_lower_latency
15:05:36 10: [2016-03-08 15:05:36.539365] mirserver: Starting
15:05:36 10: [2016-03-08 15:05:36.539747] mirserver: Selected driver: dummy (version 0.20.0)
15:05:36 10: [2016-03-08 15:05:36.541785] mirserver: Initial display configuration:
15:05:36 10: [2016-03-08 15:05:36.542037] mirserver: Using software cursor
15:05:36 10: [2016-03-08 15:05:36.543676] mirserver: Selected input driver: mir:stub-input (version: 0.20.0)
15:05:36 10: [2016-03-08 15:05:36.543864] mirserver: Mir version 0.20.0
15:05:38 10: [ debug ] 98 frames sampled, averaging 1.9 frames latency
15:05:38 10: [ debug ] 0: 0 1 1 1 2 2 2 2 2 2
15:05:38 10: [ debug ] 10: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 20: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 30: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 40: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 50: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 60: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 70: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 80: 2 2 2 2 2 2 2 2 2 2
15:05:38 10: [ debug ] 90: 2 2 2 2 2 2 2 2
15:05:38 10: /��BUILDDIR��/mir-0.20.1+16.04.20160225.1+vivid397bzr3374/tests/acceptance-tests/test_latency.cpp:350: Failure
15:05:38 10: Value of: observed_latency
15:05:38 10: Expected: is <= 1.4
15:05:38 10: Actual: 1.94898 (of type float)
15:05:38 10: [2016-03-08 15:05:38.301041] mirserver: Stopping
15:05:38 10: [ FAILED ] ClientLatency.throttled_input_rate_yields_lower_latency (1777 ms)

Related branches

Daniel van Vugt (vanvugt) wrote :

Assuming we haven't broken buffering at all, this is probably just a consequence of a very slow CI machine. Unfortunately this regression test is performance-sensitive, because it is testing real performance.

Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

I've been unable to reproduce this failure myself. And even in CI it doesn't happen very often. But it's not the only performance-related failure.

I would suggest moving such performance-sensitive acceptance tests into some mir_performance_tests2 and don't run it in CI, but then they cease to be helpful as a reliable CI check for regressions.

I think one possible way forward here is to just weaken the test so that it will pass more reliably even on slow machines. That means switching from a 59Hz generation rate to something a bit slower.

Changed in mir:
milestone: none → 0.22.0
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :

Correction: Comment #2 is not a sighting of this bug. It shows:
   [ FAILED ] NestedServer.named_cursor_image_changes_are_forwarded_to_host
and
   [ OK ] ClientLatency.throttled_input_rate_yields_lower_latency (1773 ms)

So comment #2 is actually bug 1523621.

Changed in mir:
status: New → In Progress
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.22.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.22.1+16.04.20160516.2-0ubuntu2

---------------
mir (0.22.1+16.04.20160516.2-0ubuntu2) yakkety; urgency=medium

  [ Dimitri John Ledkov ]
  * Fix FTBFS error: call of overloaded ‘abs(float)’ is ambiguous, by
    including cmath c++ header.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 19 May 2016 21:58:43 +0200

Changed in mir (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers