Mir

Activity log for bug #1540731

Date Who What changed Old value New value Message
2016-02-02 04:37:18 Daniel van Vugt bug added bug
2016-02-02 09:03:57 Daniel van Vugt mir: importance Undecided High
2016-02-02 10:54:45 Alan Griffiths mir: status New Confirmed
2016-02-02 10:54:51 Alan Griffiths mir: assignee Alan Griffiths (alan-griffiths)
2016-02-02 12:22:35 Alan Griffiths mir: importance High Critical
2016-02-02 12:27:54 Alan Griffiths summary mir_acceptance_tests [ FAILED ] PromptSessionClientAPI.client_pid_is_associated_with_session SocketMessenger::update_session_creds() fails to get client PID
2016-02-02 12:54:54 Alan Griffiths bug task added glibc
2016-02-02 15:17:28 Alan Griffiths description For some reason mir_acceptance_tests is failing for me consistently today: [ RUN ] PromptSessionClientAPI.client_pid_is_associated_with_session unknown file: Failure Unexpected mock function call - returning directly. Function call: prompt_provider_added(@0x7f1488000a20 8-byte object <A8-8E D8-E6 14-7F 00-00>, @0x7f14deaa7e70 16-byte object <F0-28 00-88 14-7F 00-00 E0-28 00-88 14-7F 00-00>) Google Mock tried the following 1 expectation, but it didn't match: /home/dan/bzr/mir/trunk/tests/acceptance-tests/test_prompt_session_client_api.cpp:399: EXPECT_CALL(*the_mock_prompt_session_listener(), prompt_provider_added(_, Not(IsSessionWithPid(server_pid))))... Expected arg #1: not (is session with pid 9532) Actual: 16-byte object <F0-28 00-88 14-7F 00-00 E0-28 00-88 14-7F 00-00> Expected: to be called once Actual: never called - unsatisfied and active /home/dan/bzr/mir/trunk/tests/acceptance-tests/test_prompt_session_client_api.cpp:399: Failure Actual function call count doesn't match EXPECT_CALL(*the_mock_prompt_session_listener(), prompt_provider_added(_, Not(IsSessionWithPid(server_pid))))... Expected: to be called once Actual: never called - unsatisfied and active [ FAILED ] PromptSessionClientAPI.client_pid_is_associated_with_session (14 ms) Since updating to the 4.4.0-2 kernel recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. This manifests as a test failure in Mir: [ RUN ] PromptSessionClientAPI.client_pid_is_associated_with_session unknown file: Failure Test case: #include <gtest/gtest.h> #include <gmock/gmock.h> #include <sys/socket.h> #include <sys/stat.h> TEST(IsItBroken, recvmsg) { using namespace testing; enum { server, client, size }; int socket_fd[size]; int const opt = 1; ASSERT_THAT(socketpair(AF_LOCAL, SOCK_STREAM, 0, socket_fd), Eq(0)); auto const msg = "A random message"; send(socket_fd[client], msg, sizeof msg, MSG_DONTWAIT | MSG_NOSIGNAL); ASSERT_THAT(setsockopt(socket_fd[server], SOL_SOCKET, SO_PASSCRED, &opt, sizeof(opt)), Ne(-1)); union { struct cmsghdr cmh; char control[CMSG_SPACE(sizeof(ucred))]; } control_un; control_un.cmh.cmsg_len = CMSG_LEN(sizeof(ucred)); control_un.cmh.cmsg_level = SOL_SOCKET; control_un.cmh.cmsg_type = SCM_CREDENTIALS; msghdr msgh; msgh.msg_name = nullptr; msgh.msg_namelen = 0; msgh.msg_iov = nullptr; msgh.msg_iovlen = 0; msgh.msg_control = control_un.control; msgh.msg_controllen = sizeof(control_un.control); errno = 0; EXPECT_THAT(recvmsg(socket_fd[server], &msgh, MSG_PEEK), Ne(-1)) << "Error: " << strerror(errno); for (auto socket : socket_fd) close(socket); }
2016-02-02 15:19:09 Alan Griffiths mir: assignee Alan Griffiths (alan-griffiths)
2016-02-02 16:21:48 Joseph Salisbury bug task added linux (Ubuntu)
2016-02-02 16:21:54 Joseph Salisbury linux (Ubuntu): status New Confirmed
2016-02-02 16:33:12 Tim Gardner bug added subscriber Tim Gardner
2016-02-02 16:59:46 Joseph Salisbury linux (Ubuntu): importance Undecided High
2016-02-02 17:00:06 Joseph Salisbury tags testsfail kernel-key performing-bisect testsfail
2016-02-02 17:00:34 Joseph Salisbury linux (Ubuntu): importance High Critical
2016-02-03 01:26:54 Daniel van Vugt summary SocketMessenger::update_session_creds() fails to get client PID SocketMessenger::update_session_creds() fails to get client PID, causing "[ FAILED ] PromptSessionClientAPI.client_pid_is_associated_with_session"
2016-02-03 07:48:07 Daniel van Vugt mir: importance Critical High
2016-02-03 10:11:35 Alan Griffiths description Since updating to the 4.4.0-2 kernel recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. This manifests as a test failure in Mir: [ RUN ] PromptSessionClientAPI.client_pid_is_associated_with_session unknown file: Failure Test case: #include <gtest/gtest.h> #include <gmock/gmock.h> #include <sys/socket.h> #include <sys/stat.h> TEST(IsItBroken, recvmsg) { using namespace testing; enum { server, client, size }; int socket_fd[size]; int const opt = 1; ASSERT_THAT(socketpair(AF_LOCAL, SOCK_STREAM, 0, socket_fd), Eq(0)); auto const msg = "A random message"; send(socket_fd[client], msg, sizeof msg, MSG_DONTWAIT | MSG_NOSIGNAL); ASSERT_THAT(setsockopt(socket_fd[server], SOL_SOCKET, SO_PASSCRED, &opt, sizeof(opt)), Ne(-1)); union { struct cmsghdr cmh; char control[CMSG_SPACE(sizeof(ucred))]; } control_un; control_un.cmh.cmsg_len = CMSG_LEN(sizeof(ucred)); control_un.cmh.cmsg_level = SOL_SOCKET; control_un.cmh.cmsg_type = SCM_CREDENTIALS; msghdr msgh; msgh.msg_name = nullptr; msgh.msg_namelen = 0; msgh.msg_iov = nullptr; msgh.msg_iovlen = 0; msgh.msg_control = control_un.control; msgh.msg_controllen = sizeof(control_un.control); errno = 0; EXPECT_THAT(recvmsg(socket_fd[server], &msgh, MSG_PEEK), Ne(-1)) << "Error: " << strerror(errno); for (auto socket : socket_fd) close(socket); } Since updating to the 4.4.0-2 kernel recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. This manifests as a test failure in Mir:     [ RUN ] PromptSessionClientAPI.client_pid_is_associated_with_session     unknown file: Failure Test case: #include <stdlib.h> #include <stdio.h> #include <sys/socket.h> #include <sys/stat.h> #include <assert.h> #include <errno.h> #include <string.h> int main() { enum { server, client, size }; int socket_fd[size]; int const opt = 1; assert(socketpair(AF_LOCAL, SOCK_STREAM, 0, socket_fd) == 0); char const msg[] = "A random message"; send(socket_fd[client], msg, sizeof msg, MSG_DONTWAIT | MSG_NOSIGNAL); assert(setsockopt(socket_fd[server], SOL_SOCKET, SO_PASSCRED, &opt, sizeof(opt)) != -1); union { struct cmsghdr cmh; char control[CMSG_SPACE(sizeof(ucred))]; } control_un; control_un.cmh.cmsg_len = CMSG_LEN(sizeof(ucred)); control_un.cmh.cmsg_level = SOL_SOCKET; control_un.cmh.cmsg_type = SCM_CREDENTIALS; msghdr msgh; msgh.msg_name = NULL; msgh.msg_namelen = 0; msgh.msg_iov = NULL; msgh.msg_iovlen = 0; msgh.msg_control = control_un.control; msgh.msg_controllen = sizeof(control_un.control); errno = 0; if (recvmsg(socket_fd[server], &msgh, MSG_PEEK) == -1) { printf("Error: %s\n", strerror(errno)); exit(EXIT_FAILURE); } else { printf("Success!\n"); exit(EXIT_SUCCESS); } }
2016-02-03 10:13:14 Alan Griffiths mir: importance High Critical
2016-02-03 12:55:28 Alan Griffiths bug watch added http://sourceware.org/bugzilla/show_bug.cgi?id=19557
2016-02-03 17:16:20 Joseph Salisbury linux (Ubuntu): importance Critical High
2016-02-03 21:46:16 kevin gunn linux (Ubuntu): importance High Critical
2016-02-03 21:46:28 kevin gunn mir: status Confirmed Opinion
2016-02-04 01:39:41 Daniel van Vugt mir: status Opinion Confirmed
2016-02-04 01:39:51 Daniel van Vugt mir: milestone 0.20.0
2016-02-04 17:18:23 Joseph Salisbury linux (Ubuntu): status Confirmed In Progress
2016-02-04 17:18:27 Joseph Salisbury linux (Ubuntu): assignee Joseph Salisbury (jsalisbury)
2016-02-05 01:20:23 Daniel van Vugt summary SocketMessenger::update_session_creds() fails to get client PID, causing "[ FAILED ] PromptSessionClientAPI.client_pid_is_associated_with_session" SocketMessenger::update_session_creds() fails to get client PID, causing "[ FAILED ] PromptSessionClientAPI.client_pid_is_associated_with_session" on kernel 4.4 (but kernel 4.3 works)
2016-02-05 13:20:40 Andy Whitcroft description Since updating to the 4.4.0-2 kernel recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. This manifests as a test failure in Mir:     [ RUN ] PromptSessionClientAPI.client_pid_is_associated_with_session     unknown file: Failure Test case: #include <stdlib.h> #include <stdio.h> #include <sys/socket.h> #include <sys/stat.h> #include <assert.h> #include <errno.h> #include <string.h> int main() { enum { server, client, size }; int socket_fd[size]; int const opt = 1; assert(socketpair(AF_LOCAL, SOCK_STREAM, 0, socket_fd) == 0); char const msg[] = "A random message"; send(socket_fd[client], msg, sizeof msg, MSG_DONTWAIT | MSG_NOSIGNAL); assert(setsockopt(socket_fd[server], SOL_SOCKET, SO_PASSCRED, &opt, sizeof(opt)) != -1); union { struct cmsghdr cmh; char control[CMSG_SPACE(sizeof(ucred))]; } control_un; control_un.cmh.cmsg_len = CMSG_LEN(sizeof(ucred)); control_un.cmh.cmsg_level = SOL_SOCKET; control_un.cmh.cmsg_type = SCM_CREDENTIALS; msghdr msgh; msgh.msg_name = NULL; msgh.msg_namelen = 0; msgh.msg_iov = NULL; msgh.msg_iovlen = 0; msgh.msg_control = control_un.control; msgh.msg_controllen = sizeof(control_un.control); errno = 0; if (recvmsg(socket_fd[server], &msgh, MSG_PEEK) == -1) { printf("Error: %s\n", strerror(errno)); exit(EXIT_FAILURE); } else { printf("Success!\n"); exit(EXIT_SUCCESS); } } Since updating to the 4.4.0-2 kernel recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. This manifests as a test failure in Mir:     [ RUN ] PromptSessionClientAPI.client_pid_is_associated_with_session     unknown file: Failure Test case: #include <stdlib.h> #include <stdio.h> #include <sys/socket.h> #include <sys/stat.h> #include <assert.h> #include <errno.h> #include <string.h> int main() {     enum { server, client, size };     int socket_fd[size];     int const opt = 1;     assert(socketpair(AF_LOCAL, SOCK_STREAM, 0, socket_fd) == 0);     char const msg[] = "A random message";     send(socket_fd[client], msg, sizeof msg, MSG_DONTWAIT | MSG_NOSIGNAL);     assert(setsockopt(socket_fd[server], SOL_SOCKET, SO_PASSCRED, &opt, sizeof(opt)) != -1);     union {         struct cmsghdr cmh;         char control[CMSG_SPACE(sizeof(ucred))];     } control_un;     control_un.cmh.cmsg_len = CMSG_LEN(sizeof(ucred));     control_un.cmh.cmsg_level = SOL_SOCKET;     control_un.cmh.cmsg_type = SCM_CREDENTIALS;     msghdr msgh;     msgh.msg_name = NULL;     msgh.msg_namelen = 0;     msgh.msg_iov = NULL;     msgh.msg_iovlen = 0;     msgh.msg_control = control_un.control;     msgh.msg_controllen = sizeof(control_un.control);     errno = 0;     if (recvmsg(socket_fd[server], &msgh, MSG_PEEK) == -1)     {         printf("Error: %s\n", strerror(errno));         exit(EXIT_FAILURE);     }     else     {         printf("Success!\n");         exit(EXIT_SUCCESS);     } } === Kernel-Description: recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP.
2016-02-08 14:18:35 Chris J Arges bug added subscriber Ubuntu Stable Release Updates Team
2016-02-08 15:26:10 Luis Henriques linux (Ubuntu): status In Progress Fix Committed
2016-02-09 02:48:25 Daniel van Vugt mir: status Confirmed Invalid
2016-02-09 16:05:20 Joseph Salisbury tags kernel-key performing-bisect testsfail performing-bisect testsfail
2016-02-10 23:49:26 Launchpad Janitor linux (Ubuntu): status Fix Committed Fix Released
2016-02-24 10:18:47 Launchpad Janitor branch linked lp:~ubuntu-branches/ubuntu/trusty/linux-lts-xenial/trusty-proposed
2016-02-24 13:07:51 Launchpad Janitor branch linked lp:~ubuntu-branches/ubuntu/trusty/linux-lts-wily/trusty-proposed
2016-03-04 10:15:34 Alan Griffiths linux (Ubuntu): status Fix Released Confirmed
2016-03-04 17:19:41 Joseph Salisbury linux (Ubuntu): status Confirmed In Progress
2016-03-04 17:19:51 Joseph Salisbury tags performing-bisect testsfail performing-bisect testsfail trusty wily
2016-03-15 16:05:35 Brad Figg nominated for series Ubuntu Trusty
2016-03-15 16:05:35 Brad Figg bug task added linux (Ubuntu Trusty)
2016-03-15 16:05:44 Brad Figg linux (Ubuntu Trusty): status New Fix Committed
2016-03-15 17:53:24 Brad Figg nominated for series Ubuntu Vivid
2016-03-15 17:53:24 Brad Figg bug task added linux (Ubuntu Vivid)
2016-03-15 17:53:32 Brad Figg linux (Ubuntu Vivid): status New Fix Committed
2016-03-21 14:54:55 Kamal Mostafa tags performing-bisect testsfail trusty wily performing-bisect testsfail trusty verification-needed-trusty wily
2016-03-21 14:55:14 Kamal Mostafa tags performing-bisect testsfail trusty verification-needed-trusty wily performing-bisect testsfail trusty verification-needed-trusty verification-needed-vivid wily
2016-04-05 08:51:38 Launchpad Janitor linux (Ubuntu Trusty): status Fix Committed Fix Released
2016-04-05 08:53:56 Launchpad Janitor linux (Ubuntu Vivid): status Fix Committed Fix Released
2016-09-30 16:28:47 Joseph Salisbury tags performing-bisect testsfail trusty verification-needed-trusty verification-needed-vivid wily performing-bisect testsfail trusty verification-done-trusty verification-done-vivid wily
2017-03-03 18:09:10 Joseph Salisbury linux (Ubuntu): status In Progress Fix Released