Mir

[regression] Mir servers crash on mouse input - std::exception::what: Client input channel write blocked : 11, "Resource temporarily unavailable"

Bug #1528438 reported by Daniel van Vugt
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
kevin gunn
Mir
Fix Released
Critical
Daniel van Vugt
0.18
Invalid
Critical
Unassigned
mir (Ubuntu)
Undecided
Unassigned

Bug Description

[regression] Mir servers crash on client input - std::exception::what: Client input channel write blocked : 11, "Resource temporarily unavailable"

ERROR: /home/dan/bzr/mir/trunk/src/server/input/android/input_sender.cpp(197): Throw in function void mir::input::android::InputSender::ActiveTransfer::send(uint32_t, const MirEvent&)
Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::runtime_error> >
std::exception::what: Client input channel write blocked :
11, "Resource temporarily unavailable"

Test case:
  1. Start a Mir server
  2. Start a non-input Mir client like mir_demo_client_scroll or mir_demo_client_flicker

Expected: Client ignores mouse input and keeps working.
Observed: Server crashes on mouse motion over the client (scroll) or on mouse click (flicker)

The bug appears to be in lp:mir only. Not in lp:mir/0.18

Related branches

description: updated
summary: - [regression] Mir servers crash on client input - std::exception::what:
+ [regression] Mir servers crash on mouse input - std::exception::what:
Client input channel write blocked : 11, "Resource temporarily
unavailable"
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Bisected. The exception (which should not be an exception) was introduced in:

------------------------------------------------------------
revno: 3212 [merge]
author: Andreas Pokorny <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Sat 2015-12-19 01:43:39 +0000
message:
  Remove the unused InpoutSendObserver

  InputSendObserver was an interface necessary to allow the android::InputDispatcher to directly send events through the Surface, back then when we added the shell defined input dispatcher interface to mir. This step was never done, instead we just replaced the android::InputDispatcher. This part is now removed and thus simplifies the InputSender a lot.

  Approved by Kevin DuBois, Alberto Aguirre, PS Jenkins bot.
------------------------------------------------------------

Changed in mir:
status: New → Triaged
Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.19.0

Changed in mir:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → kevin gunn (kgunn72)
milestone: none → ww04-2016
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.19.0+16.04.20160128-0ubuntu1

---------------
mir (0.19.0+16.04.20160128-0ubuntu1) xenial; urgency=medium

  [ Brandon Schaefer ]
  * New upstream release 0.19.0
    - API summary:
      . mirclient abi unchanged at 9
      . mirserver abi bumped to 37
      . mircommon abi unchanged at 5
      . mirplatform abi unchanged at 11
      . mirprotobuf abi unchanged at 3
      . mirplatformgraphics abi bumped to 7
      . mirclientplatform abi bumped to 4
      . mirinputplatform abi bumped to 5
      . mircookie abi bumped to 2
    - Bug fix:
      . Mir servers crash on mouse input (LP: #1528438)
      . Pinch to zoom not working reliably (LP: #1531517)
      . Passing DisplayConfiguration scale property from
        nested server to host appears to not work (LP: #1535780)
      . Various TSan reports when running test suite
        on a mir tsan enabled build (LP: #1523647)
      . Buffer leak during repeated mirscreencasts
        causes server to be killed (LP: #1523900)
      . Cursor now displays correctly (LP: #1526779)
      .ProgramOption::parse_file() reports problems to cerr (LP: #1190165)
      . Nested servers can select wrong platform (LP: #1515558)
      . There seems to be missing RTTI information
         when linking with UBSan enabled (LP: #1521930)
      . Mir threadsanitizer build fails with GCC (LP: #1522581)
      . After "make install" mir_demo_server cannot
        find shared object file in /usr/local/lib (LP: #1522836)
      . Fixed a test in TestClientInput (LP: #1523965)
      . Mir servers choose graphics-dummy (or no driver at all)
        over mesa-kms on a desktop (LP: #1528082)
      . Function mir_event_get_close_surface_event is never used (LP: #1447690)
      . mir::input::Surface::consume(MirEvent const& event)
        should not take a reference to an opaque type (LP: #1450797)
      . lintian: E: mir-doc: privacy-breach-logo (LP: #1483471)

  [ CI Train Bot ]
  * No-change rebuild.

 -- Brandon Schaefer <email address hidden> Thu, 28 Jan 2016 12:19:47 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
milestone: ww04-2016 → 9.1
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers