Mir

[regression] arm64/powerpc cross compile doesn't build any more

Bug #1510778 reported by Daniel van Vugt on 2015-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Medium
Unassigned

Bug Description

[regression] arm64 cross compile doesn't build any more.

Support for generic architecture cross compilation (including arm64) was added in Mir 0.16. You can use it with:

   sudo apt-get install g++-aarch64-linux-gnu gcc-aarch64-linux-gnu
  ./cross-compile-chroot.sh -a arm64 -d wily

However it's presently failing in lp:mir and lp:mir/0.17. Still works in lp:mir/0.16 though.

Related branches

Daniel van Vugt (vanvugt) wrote :

Seems like there are a couple of issues. But the first one came in:

------------------------------------------------------------
revno: 2955 [merge]
author: Cemil Azizoglu <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Tue 2015-09-22 06:45:45 +0000
message:
  [integration tests] Generate binaries for both mesa backends for mesa related integration tests when either mesa platform is active.

  Approved by PS Jenkins bot, Daniel van Vugt, Alan Griffiths.
------------------------------------------------------------

Daniel van Vugt (vanvugt) wrote :

Oh. Seems my system only worked because I had good ~/.cache contents. But another regression happened here:

------------------------------------------------------------
revno: 2914 [merge]
author: Andreas Pokorny <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Thu 2015-09-10 12:55:15 +0000
message:
  Add a parameter to select additional deb repositories to get the chroot packag
es

  With this the script implementation switches from debootstrap to multistrap. .

  Approved by Alan Griffiths, Alexandros Frantzis, PS Jenkins bot.
------------------------------------------------------------

which seemingly went into 0.16.0 and makes the script seek armhf instead of arm64.

Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
milestone: none → 0.18.0
summary: - [regression] arm64 cross compile doesn't build any more
+ [regression] arm64/powerpc cross compile doesn't build any more
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.18.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (6.3 KiB)

This bug was fixed in the package mir - 0.18.0+16.04.20151216.1-0ubuntu1

---------------
mir (0.18.0+16.04.20151216.1-0ubuntu1) xenial; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.18.0 (https://launchpad.net/mir/+milestone/0.18.0)
    - ABI summary: Only servers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 36
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI unchanged at 11
      . Mirprotobuf ABI unchanged at 3
      . Mirplatformgraphics ABI bumped to 7
      . Mirclientplatform ABI unchanged at 3
      . Mirinputplatform ABI added. Current version is 4
    - Enhancements:
      . Use libinput by default, and remove the android input stack
      . Add x11 input probing
      . Add alternative buffer swapping mechanism internally, available with
        --nbuffers 0
      . Automatic searching and selection of input platforms
      . Better support for themed cursors
      . Add demo client that uses multiple buffer streams in one surface
      . Improve fingerpaint demo to use touch pressure
      . Allow for configuring cursor acceleration, scroll speed and left or
        right handed mice
      . Allow for setting a base display configuration via client api
      . Various nested server multimonitor fixes and stability improvements
      . Remove DepthId from the SurfaceStack
    - Bug fixes:
      . Unit test failures in Display.* on Android (LP: #1519276)
      . Build failure due to missing dependency of client rpc code on mir
        protobuf (LP: #1518372)
      . Test failure in
        NestedServer.display_configuration_reset_when_application_exits
        (LP: #1517990)
      . CI test failures in various NesterServer tests (LP: #1517781)
      . FTBFS with -DMIR_PLATFORM=android (LP: #1517532)
      . Nesting Mir servers with assorted display configs causes lockup
        (LP: #1516670)
      . [testsfail] RaiseSurfaces.motion_events_dont_prevent_raise
        (LP: #1515931)
      . CI test failures in GLMark2Test (LP: #1515660)
      . Shells that inject user input events need to agree with the system
        compositor on the clock to use (LP: #1515515)
      . mircookie-dev is missing nettle-dev dependency (LP: #1514391)
      . Segmentation fault on server shutdown with mesa-kms (LP: #1513901)
      . mircookie requires nettle but libmircookie-dev doesn't depend on it
        (LP: #1513792)
      . libmircookie1 package does not list libnettle as dependency
        (LP: #1513225)
      . display configuration not reset when application exits (LP: #1511798)
      . unplugging external monitor causes nested server to throttle client
        (LP: #1511723)
      . 1/2 screen on external monitor (LP: #1511538)
      . unity-system-compositor crash, no interaction on windowed mode
        (LP: #1511095)
      . [regression] arm64/powerpc cross compile doesn't build any more
        (LP: #1510778)
      . mir_connection_get_egl_pixel_format() crashes if libEGL is loaded
        RTLD_LAZY (LP: #1510218)
      . [multimonitor] nested server surface positioning incorrect
        (LP: #1506846)
      . unity-system-compositor fails to build against lp:mir r3027
   ...

Read more...

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Kevin DuBois (kdub) on 2015-12-22
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers