Mir

Mir suddenly no longer builds since Mesa 11.0 was introduced: /usr/include/EGL/eglplatform.h:100:35: fatal error: android/native_window.h: No such file or directory

Bug #1499134 reported by Daniel van Vugt on 2015-09-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Critical
Chris Halse Rogers
0.15
Won't Fix
Critical
Daniel van Vugt
0.16
Fix Released
Critical
Chris Halse Rogers
mir (Ubuntu)
Critical
Unassigned
Nominated for Vivid by Daniel van Vugt

Bug Description

Mir suddenly no longer builds on wily desktop:

In file included from /usr/include/EGL/egl.h:39:0,
                 from /home/dan/bzr/mir/trunk/include/platform/mir/graphics/platform.h:24,
                 from /home/dan/bzr/mir/trunk/src/platforms/android/server/android_buffer_allocator.cpp:20:
/usr/include/EGL/eglplatform.h:100:35: fatal error: android/native_window.h: No such file or directory
compilation terminated.
src/platforms/android/server/CMakeFiles/mirplatformgraphicsandroidobjects.dir/build.make:77: recipe for target 'src/platforms/android/server/CMakeFiles/mirplatformgraphicsandroidobjects.dir/android_buffer_allocator.cpp.o' failed
make[2]: *** [src/platforms/android/server/CMakeFiles/mirplatformgraphicsandroidobjects.dir/android_buffer_allocator.cpp.o] Error 1
CMakeFiles/Makefile2:2322: recipe for target 'src/platforms/android/server/CMakeFiles/mirplatformgraphicsandroidobjects.dir/all' failed
make[1]: *** [src/platforms/android/server/CMakeFiles/mirplatformgraphicsandroidobjects.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

Did build-deps change?

Related branches

Changed in mir:
importance: Undecided → Critical
milestone: none → 0.17.0

Seems the trigger for this issue was the landing of Mesa 11.0 in wily.

summary: - [wily] Mir suddenly no longer builds:
+ Mir suddenly no longer builds since 'mesa (11.0.0-1ubuntu1) wily':
/usr/include/EGL/eglplatform.h:100:35: fatal error:
android/native_window.h: No such file or directory
Changed in mir:
status: New → In Progress
assignee: nobody → Chris Halse Rogers (raof)
Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.16 at revision 2951, scheduled for release in Mir 0.16.1

no longer affects: ubuntu
Changed in mir (Ubuntu):
importance: Undecided → Critical
Changed in mir (Ubuntu):
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

Actually it's not fixed in Ubuntu yet, as shown by bug 1506045 and:
https://launchpad.net/ubuntu/+source/mir

Changed in mir (Ubuntu):
status: Fix Released → Triaged
tags: added: ftbfs
summary: - Mir suddenly no longer builds since 'mesa (11.0.0-1ubuntu1) wily':
+ Mir suddenly no longer builds since Mesa 11.0 was introduced:
/usr/include/EGL/eglplatform.h:100:35: fatal error:
android/native_window.h: No such file or directory
Changed in mir:
status: Fix Committed → Fix Released
Changed in mir (Ubuntu):
status: Triaged → Fix Released
Changed in mir (Ubuntu):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package mir - 0.17.0+15.10.20151008.2-0ubuntu1

---------------
mir (0.17.0+15.10.20151008.2-0ubuntu1) wily; urgency=medium

  [ Alexandros Frantzis ]
  * New upstream release 0.17.0 (https://launchpad.net/mir/+milestone/0.17.0)
    - ABI summary: Only servers and graphics drivers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 35
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI bumped to 11
      . Mirprotobuf ABI bumped to 3
      . Mirplatformgraphics ABI bumped to 6
      . Mirclientplatform ABI unchanged at 3
    - Enhancements:
      . Introduce libmircookie, a simple mechanism for a group of cooperating
        processes to hand out and verify difficult-to-forge timestamps to
        untrusted 3rd parties.
      . More refactorings to support renderers other than GL.
      . Add MirBlob to the client API - a tool for serializing and
        deserializing data.
      . Introduce a libinput based input platform, not yet used by default.
      . Provide a mechanism for the shell to send events on surface
        construction.
      . Provide mir::shell::DisplayConfigurationController allowing shells
        to correctly change the display configuration, notifying clients
        as appropriate.
      . New DSO versioning guide.
      . Send events pertaining to the output a surface is currently on (dpi,
        form factor, scale) to clients.
    - Bug fixes:
      . [enhancement] XMir specific documentation should live in its own
        subsection (LP: #1200114)
      . Nested servers need cursor support (LP: #1289072)
      . Mir cursor is missing/invisible until the client sets it multiple
        times (LP: #1308133)
      . [regression] Fullscreen software surfaces (like Xmir -sw) can crash
        the Mir server (LP: #1493721)
      . [usc] Mir gives up and shuts down due to input with multimonitor qtmir
        (std::exception::what: Failure sending input event) (LP: #1496069)
      . Mouse cursor disappears upon entering the surface area of a nested
        client (LP: #1496849)
      . [android] input is not dispatched when attaching an external monitor
        (LP: #1498045)
      . [android] input coordinates are scaled incorrectly when an external
        display is connected (LP: #1498540)
      . [android] std::exception::what: error during hwc set() when unplugging
        external monitor (LP: #1498550)
      . tests do not compile without precompiled headers (LP: #1498829)
      . [android] std::exception::what: Failed to monitor fd: Operation not
        permitted when unplugging external display in a nested configuration
        (LP: #1499042)
      . Mir suddenly no longer builds since 'mesa (11.0.0-1ubuntu1) wily':
        /usr/include/EGL/eglplatform.h:100:35: fatal error:
        android/native_window.h: No such file or directory (LP: #1499134)
      . [android] various crashes when unplugging external display on a
        nested configuration (LP: #1501927)
      . Cursor becomes visible by itself when an external monitor is connected
        (LP: #1502200)
      . mesa FTBFS due to missing Requires in mirclient (LP: #1503450)

  [ CI Trai...

Read more...

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Daniel van Vugt (vanvugt) wrote :

I need a fix for this bug in lp:mir/0.15 too, in order to set up a test environment for LP: #1507982.

So may as well commit it to lp:mir/0.15 (which is otherwise deprecated) in case anyone else wants it.

Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.15 at revision 2835. Not scheduled for release. Ever.

Daniel van Vugt (vanvugt) wrote :

Fix committed but never going to be released.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers