Mir

[trusted prompt sessions] Can't open two prompt sessions at the same time

Bug #1494197 reported by quandan on 2015-09-10
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alan Griffiths
mir (Ubuntu)
Undecided
Unassigned

Bug Description

current build number: 109
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en
last update: 2015-09-10 06:07:46
version version: 109
version ubuntu: 20150910
version device: 20150818-0b38025
version custom: 20150814-887-8-46

Steps:
1. Open the note app , and it opens at the regesiter page
2.Don't sign in the note account and open twitter app

Expectation:
After step 2#,we can open the twitter ,and it will at the sign in page

Actual result:
 we can't open twitter account ,there is a hint that we can only open one account at the same time :Account window could not be opened. You can only create one account at a time ;please try again after closing all other account windows.

Note: I attached a screenshot

Related branches

quandan (2508837716-y) wrote :
Alberto Mardegan (mardy) wrote :

Reassigning to Mir. This bug happens because only one trust session can be opened at a given time.

affects: ubuntu-system-settings-online-accounts (Ubuntu) → mir
Alan Griffiths (alan-griffiths) wrote :

It is true that only one prompt session can be created on each connection. (There's code there to prevent a second one being created.)

I'll have to look out the design documents to find the reason why and assess whether it is still a requirement.

Alan Griffiths (alan-griffiths) wrote :

It's pretty clear from the lp:1355173 comments that this behaviour is intentional and due to be revisited in a future iteration of trusted prompt sessions.

The (internal) doc "Application Embedding & Trusted Helpers" also lists "Allow for multiple concurrent trust sessions" among other items for "Implementation - Phase II".

When we to consider this feature (it sounds like the right time may be "soon"), we ought to look at the related features from that phase and assess their impact on other projects.

Changed in mir:
status: New → Triaged
importance: Undecided → Wishlist
Changed in mir:
milestone: none → 0.16.0
assignee: nobody → Alan Griffiths (alan-griffiths)
assignee: Alan Griffiths (alan-griffiths) → nobody
milestone: 0.16.0 → none
Alberto Mardegan (mardy) wrote :

Any plans to tackle this bug "soon"? :-)

summary: - we can't open two account at the same time
+ [trusted prompt sessions] Can't open two accounts at the same time

But... i am opening one account at the same time and i still get thisa error. I cant open for example facebook client like this.

Alan Griffiths (alan-griffiths) wrote :

You are only dealing with one account. The comments suggest this scenario requires two trust prompt sessions. That's a feature that belongs to "phase 2" of trusted prompt sessions. I'm not sure where we stand with implementing any of the "phase 2" features.

summary: - [trusted prompt sessions] Can't open two accounts at the same time
+ [trusted prompt sessions] Can't open two prompt sessions at the same
+ time
Cemil Azizoglu (cemil-azizoglu) wrote :

Upped the priority since Saviq's team needs this.

Changed in mir:
importance: Wishlist → High
Ken VanDine (ken-vandine) wrote :

The content-hub-service needs to be able to start prompt sessions for multiple requests. Use cases:

1. Paste Other from the UITK's TextField invokes the clipboard UI as a trust prompt started by content-hub-service
2. Out of process peer picker, we have a new peer picker that doesn't run in the process of the requesting app. It's started in a prompt session by content-hub-service
3. Content picking. The content-hub-service starts apps that provide a content picker in a trust prompt.
4. Printing dialog is started by the content-hub-service.

All of these use cases require starting the prompt from the content-hub-service process. We would like to do this without stopping other prompts that might already be in use.

Changed in mir:
assignee: nobody → Alan Griffiths (alan-griffiths)
milestone: none → 0.26.0
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.26.0

Changed in mir:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (7.2 KiB)

This bug was fixed in the package mir - 0.26.0+17.04.20170126.3-0ubuntu1

---------------
mir (0.26.0+17.04.20170126.3-0ubuntu1) zesty; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.0 (https://launchpad.net/mir/+milestone/0.26.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 43
      . mircommon ABI unchanged at 7
      . mirplatform ABI unchanged at 14
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 11
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 6
      . mircore ABI unchanged at 1
    - Enhancements:
      . New/improved toolkit APIs: MirInputConfig and related functions,
        MirWindow and related functions, DisplayConfig and related functions,
        MirScreencastSpec and related functions,
      . Support for configuring input configuration
      . Introduce toolkit extension mechanism for platform specific APIs.
      . Toolkit extensions for: mesa_drm_auth, set_gbm_device and
        window_coordinate_translation
      . Screencasting to a specific MirBuffer.
      . Add DisplayConfigurationController::base_configuration() so downstreams
        can get the base configuration. (Weirdly they can already set it.).
      . x11 platform: allow adjustable scale parameter.
      . Added EDID support: client API, server logging and in mirout.
      . mirout: Add newer attributes only available in the new display
        config API: scaling factor, subpixel arrangement and form factor.
      . mirout: Log the orientation and logical size of each output too.
      . Replace the mir::Server-overridable Reports with Observers.
      . Add xkbcommon to mirclient.pc Requires.private.
      . Deprecate legacy toolkit APIs that will be removed in Mir 1.0
      . Introduced 'client-side vsync', which dramatically reduces latency
        from the client to the screen (particularly for nested servers like
        Unity8).
    - Bugs fixed:
      . [performance] Restore support for better-than-triple buffering by
        default. (LP: #1240909)
      . Frame rate is artificially low on Diamondville Intel Atom systems due
        to aggressive power management (LP: #1388490)
      . [testsfail] failure in CI in
        AndroidInputReceiverSetup.slow_raw_input_doesnt_cause_frameskipping
        (LP: #1394369)
      . [trusted prompt sessions] Can't open two prompt sessions at the same
        time (LP: #1494197)
      . Changing scale, formFactor or DPI in display configuration causes
        renderer teardown/recreate unnecessarily (LP: #1556142)
      . [testsfail] ApplicationNotRespondingDetection.failure_to_pong_is_
        noticed (LP: #1570327)
      . CI failure in TestClientInput.receives_one_touch_event_per_frame
        (LP: #1570698)
      . Mir-on-X mouse input is jerky/stuttery compared to Mir-on-KMS
        (LP: #1576600)
      . [regression] Two fingers in mir_proving_server now resizes/moves app
        windows (two finger apps unusable) (LP: #1586311)
      . Pointer/cursor input lag in unity8 session (LP: #1591328)
      . PointerConfinement.test_we_update_our_confined_region_on_a_resize
      ...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers