Mir

[regression] [multimonitor] Clients (sometimes) run at double frame rate if overlapping two monitors.

Bug #1420678 reported by Daniel van Vugt on 2015-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Medium
Unassigned

Bug Description

[regression] [multimonitor] Clients sometimes run at double frame rate if overlapping two monitors. Whether or not they do seems somewhat unpredictable. Depends how many times they cross monitor boundaries.

Related branches

tags: added: multimonitor
summary: - [regression] [multimonitor] Clients run at double frame rate if
- overlapping two monitors.
+ [regression] [multimonitor] Clients (sometimes) run at double frame rate
+ if overlapping two monitors.
description: updated
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Even weirder - the clients stay at double framerate any time they come within 50-100 pixels of the shared edge (!?). Not even touching the screen edge.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

OK, the weirdness is less weird. It's just the edge of the shadow touching the screen edge I think.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Found the source of the regression:

------------------------------------------------------------
revno: 2183 [merge]
author: Daniel van Vugt <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Fri 2014-12-19 21:52:32 +0000
message:
  Split post_update() into separate gl_swap_buffers() and flip().

  On some platforms this provides a significant performance boost, as
  GL resources and client buffers can be released after the gl_swap_buffers
  without having to wait for the flip.

  This solves most of LP: #1264934, and unblocks work on LP: #1350716 and
  possibly unblocks LP: #1350725 too. Fixes: https://bugs.launchpad.net/bugs/1264934, https://bugs.launchpad.net/bugs/1350716.

  Approved by Alberto Aguirre, Cemil Azizoglu, Alan Griffiths, PS Jenkins bot, Robert Carr.
------------------------------------------------------------

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Oh, I see. The timerless multi-monitor frame sync algorithm (which is awesome) can't coexist with the speedup of r2183 (which is also awesome).

We need a new approach to multi-monitor frame sync if we're going to continue living with high-performance compositing (r2183). Ideally without losing either.

Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.12.0

Changed in mir:
status: In Progress → Fix Committed
Kevin DuBois (kdub) on 2015-02-24
Changed in mir:
milestone: 0.12.0 → 0.13.0
Changed in mir (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in mir:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.13.1+15.10.20150520-0ubuntu1

---------------
mir (0.13.1+15.10.20150520-0ubuntu1) wily; urgency=medium

  [ Cemil Azizoglu ]
  * New upstream release 0.13.1 (https://launchpad.net/mir/+milestone/0.13.1)
    - ABI summary: No ABI break. Servers and clients do not need rebuilding.
      . Mirclient ABI unchanged at 8
      . Mircommon ABI unchanged at 4
      . Mirplatform ABI unchanged at 7
      . Mirserver ABI unchanged at 31
    - Bug fixes:
      . Can't load app purchase UI without a U1 account (LP: #1450377)
      . Crash because uncaught exception in mir::events::add_touch (LP: #1437357)

 -- CI Train Bot <email address hidden> Wed, 20 May 2015 21:20:15 +0000

Changed in mir (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers