Mir

mesa::DisplayBuffer::post_update is triple buffered - more laggy than it needs to be

Bug #1350725 reported by Daniel van Vugt on 2014-07-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Undecided
Unassigned

Bug Description

Our DisplayBuffer implementation for Mesa/desktop is actually triple buffered, making it one frame more laggy than it needs to be. This was intentional because it's required to allow cloned displays to keep up (waiting for all vblanks may take an extra 16ms).

But we don't need to keep it always-on. We can revert to double buffering in the common case where cloning is not active by adding this to the bottom of mesa::DisplayBuffer::post_update -

    if (outputs.size() == 1)
        wait_for_page_flip();

Making this change results in a noticeable improvement in responsiveness when dragging windows around.

Related branches

Daniel van Vugt (vanvugt) wrote :

Just re-tested this, and while still true, discovered a problem.

My high-end quad-core i7 system can't keep up with compositing if I throw 10+ triangles at it use enable double-buffering. It requires the display buffer to remain triple buffered to keep up. Sounds like we need to work on the efficiency of our compositing before it's feasible to resolve this bug, if ever.

Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → Won't Fix
Daniel van Vugt (vanvugt) wrote :

Blocked by bug 1377872, which I think is solvable. Then this bug can be fixed.

Changed in mir:
status: Won't Fix → Triaged
description: updated
Changed in mir:
milestone: none → 0.9.0
status: Triaged → In Progress
Changed in mir:
milestone: 0.9.0 → 0.10.0
Daniel van Vugt (vanvugt) wrote :

On hold. I think it's blocked by the more major performance issue of bug 1395421.

Changed in mir:
milestone: 0.10.0 → none
status: In Progress → Triaged
Daniel van Vugt (vanvugt) wrote :

Slightly unblocked and improved by the landing of:
   lp:~vanvugt/mir/swap-then-flip

The intel driver bug 1377872 remains the blocking issue. Although visibility of that bug is halved since swap-then-flip landed.

Changed in mir:
milestone: none → 0.10.0
status: Triaged → In Progress
Changed in mir:
milestone: 0.10.0 → 0.11.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.11.0

Changed in mir:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package mir - 0.11.0+15.04.20150209.1-0ubuntu1

---------------
mir (0.11.0+15.04.20150209.1-0ubuntu1) vivid; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.11.0 (https://launchpad.net/mir/+milestone/0.11.0)
    - Enhancements:
      . Lots more major plumbing in the Android code, on the path to
        supporting external displays.
      . Add support for clang 3.6.
      . Major redesign of server classes in mir::shell,scene and friends
        (still in progress).
      . Added client API for creating dialogs and tooltips.
      . Added new surface states: mir_surface_state_hidden and
        mir_surface_state_horizmaximized.
      . Performance: Use optimally efficient fragment shading when possible.
      . Performance: (Desktop) Composite using double buffering instead of
        triple to reduce visible lag.
      . mir_proving_server: Can now resize windows from any edge or corner
        using the existing Alt+middlebuttondrag.
      . mir_proving_server: Added some demo custom shaders (negative and
        high contrast modes: Super+N/C).
      . mir_proving_server: Can now close clients politely via Alt+F4.
      . Added MirPointerInputEvent (part of the new input API, the old
        MirMotionEvent is still supported also for now).
    - ABI summary: Servers need rebuilding, but clients do not;
      . Mirclient ABI unchanged at 8
      . Mircommon ABI unchanged at 3
      . Mirplatform ABI bumped to 6
      . Mirserver ABI bumped to 29
    - Bug fixes:
      . [regression] mir_demo_server exits immediately with boost
        bad_any_cast exception (LP: #1414630)
      . need way to position menus and tooltips (relative positioning to
        parent) (LP: #1324101)
      . GLibMainLoopTest failure seen in CI (LP: #1413748)
      . Clang builds fail in CI (LP: #1416317)
      . segfault in mir::compositor::GLProgramFamily::Shader::init()
        (LP: #1416482)
      . GLRenderer: The default fragment shader is sub-optimal for alpha=1.0
        (LP: #1350674)
      . mesa::DisplayBuffer::post_update is triple buffered - more laggy than
        it needs to be (LP: #1350725)
      . Cannot connect to nested server when started from a differen vt
        (LP: #1379266)
      . [testfail] AsioMainLoopAlarmTest fails in CI (LP: #1392256)
      . Compositor report inconsistently reports frame time during bypass,
        and render time otherwise (LP: #1408906)
      . [regression] mir_demo_client_fingerpaint doesn't paint anything any
        more (with the mouse) (LP: #1413139)
      . Hardware cursor is always slightly ahead of the composited image
        (LP: #1274408)
      . integration tests are outputting (too many) DisplayServer log
        messages (LP: #1408231)
      . [regression] deploy-and-test.sh doesn't work any more (unless you
        have umockdev installed already) (LP: #1413479)
      . Color Inverse on display. Toggle Negative Image (LP: #1400580)
      . mir-ubuntu-vivid-armhf-ci fails consistently (LP: #1407863)
      . Double-buffered surfaces may lag or freeze if event driven and not
        constantly redrawing (LP: #1395581)
      . Pointer motion and crossing events...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers