Mir

Intermittent hang & fail in mir_acceptance_tests.TestClientCursorAPI.*

Bug #1332011 reported by Alan Griffiths on 2014-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Mir development team
mir (Ubuntu)
Medium
Unassigned

Bug Description

I'm building on 64bit trusty, error happens with both g++ and clang++

Doesn't happen often - maybe twice in past day.

        Start 25: mir_acceptance_tests.TestClientCursorAPI.*
 25/204 Test #25: mir_acceptance_tests.TestClientCursorAPI.* .................................***Failed 60.02 sec
...
99% tests passed, 1 tests failed out of 204

Total Test time (real) = 74.45 sec

The following tests FAILED:
  25 - mir_acceptance_tests.TestClientCursorAPI.* (Failed)
Errors while running CTest

~~~~

With a bit of investigation using:

$ bin/mir_acceptance_tests --gtest_filter=TestClientCursorAPI.* --gtest_break_on_failure --gtest_repeat=100
...
Repeating all tests (iteration 8) . . .
...
unknown file: Failure
C++ exception with description "Timeout while waiting for child to change state" thrown in TearDown().
Segmentation fault (core dumped)
....
Repeating all tests (iteration 40) . . .
...
unknown file: Failure
C++ exception with description "Timeout while waiting for child to change state" thrown in TearDown().
Segmentation fault (core dumped)
...
Repeating all tests (iteration 88) . . .
...
unknown file: Failure
C++ exception with description "Timeout while waiting for child to change state" thrown in TearDown().
Segmentation fault (core dumped)
...
Repeating all tests (iteration 12) . . .
...
unknown file: Failure
C++ exception with description "Poll on readfd for pipe timed out" thrown in the test body.
unknown file: Failure
C++ exception with description "Timeout while waiting for child to change state" thrown in TearDown().
Segmentation fault (core dumped)

So not too hard to reproduce.

Related branches

Revision history for this message
Alan Griffiths (alan-griffiths) wrote :
Revision history for this message
Alexandros Frantzis (afrantzis) wrote :

Cannot reproduce locally, but I have seen a possibly related error in https://jenkins.qa.ubuntu.com/job/mir-team-mir-development-branch-utopic-amd64-ci/466/console

tags: added: testsfail
Changed in mir:
status: New → Fix Committed
Changed in mir:
importance: Undecided → Medium
assignee: nobody → Mir development team (mir-team)
milestone: none → 0.4.0
Changed in mir:
status: Fix Committed → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

mir (0.4.0+14.10.20140701.1-0ubuntu1) utopic; urgency=medium

Changed in mir (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers