Mir

Ubuntu Touch Settings and terminal apps are not rendering correctly on rotate.

Bug #1294048 reported by Dave Morley
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Alberto Aguirre
mir (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

In r234 the settings and terminal apps are not rendering correctly on rotate.

Open settings or terminal app
Rotate the mako into landscape then back to portrait and the image is off by 2° if you give it a few seconds or touch the screen it should right itself.

Related branches

Dave Morley (davmor2)
tags: added: mako r243 regression
Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :

Feels like the screen just isn't updating every frame, as with bug 1294053. So the final frames where it lands on the right rotation are dropped and not seen until the screen is forcibly updated by a touch event.

Changed in mir:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Didier Roche-Tolomelli (didrocks) wrote :

Confirmed this is due to the Mir landing.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.1.7+14.04.20140318-0ubuntu1

---------------
mir (0.1.7+14.04.20140318-0ubuntu1) trusty; urgency=low

  [ Alberto Aguirre ]
  * Fix not compositing the client's last posted buffer (LP: #1294048,
    LP: #1294051, LP: #1294053, LP: #1290306) In single-display cases
    the number of ready buffers decreases after a buffer is acquired by
    the rendering operator. Determine if there will be uncomposited
    buffers before acquiring a buffer so it works for single and multi
    display use cases. (LP: #1294048, #1290306, #1294051, #1294053)
 -- Ubuntu daily release <email address hidden> Tue, 18 Mar 2014 18:38:01 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Confirmed → In Progress
assignee: nobody → Alberto Aguirre (albaguirre)
milestone: none → 0.1.8
summary: - Touch has a rotate issue
+ Ubuntu Touch Settings and terminal apps are not rendering correctly on
+ rotate.
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir/devel at revision 1486, scheduled for release in mir, milestone Unknown

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers