Mir

Integration tests TestClientIPCRender.test_accelerated_render fails on Galaxy Nexus and Nexus4

Bug #1272597 reported by Kevin DuBois on 2014-01-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Kevin DuBois
mir (Ubuntu)
Medium
Unassigned

Bug Description

lp:mir/devel on galaxy nexus:

[ RUN ] TestClientIPCRender.test_accelerated_render
/home/kdub/source/mir/bq/tests/integration-tests/client/test_client_render.cpp:389: Failure
Value of: render_accelerated_process->wait_for_termination().succeeded()
  Actual: false
Expected: true
/home/kdub/source/mir/bq/tests/integration-tests/client/test_client_render.cpp:394: Failure
Value of: red_pattern.check(*region0)
  Actual: false
Expected: true
[ FAILED ] TestClientIPCRender.test_accelerated_render (702 ms)
[ RUN ] TestClientIPCRender.test_accelerated_render_double
/home/kdub/source/mir/bq/tests/integration-tests/client/test_client_render.cpp:404: Failure
Value of: render_accelerated_process_double->wait_for_termination().succeeded()
  Actual: false
Expected: true
/home/kdub/source/mir/bq/tests/integration-tests/client/test_client_render.cpp:408: Failure
Value of: red_pattern.check(*region0)
  Actual: false
Expected: true
/home/kdub/source/mir/bq/tests/integration-tests/client/test_client_render.cpp:412: Failure
Value of: green_pattern.check(*region1)
  Actual: false
Expected: true
[ FAILED ] TestClientIPCRender.test_accelerated_render_double (710 ms)

Related branches

Kevin DuBois (kdub) wrote :

easy fix, test was creating two surfaces. mako is fine with this, but it breaks the galaxy nexus, whose powerVR chipset doesn't like one buffer registered/mapped twice in the same process

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir/devel at revision None, scheduled for release in mir, milestone Unknown

Changed in mir:
status: New → Fix Committed
Daniel van Vugt (vanvugt) wrote :

You didn't notice this bug was a duplicate of bug 1253175 :)

Changed in mir:
milestone: none → 0.1.5
summary: - galaxy nexus TestClientIPCRender failure
+ Integration tests TestClientIPCRender.test_accelerated_render fails on
+ Galaxy Nexus and Nexus4
Daniel van Vugt (vanvugt) wrote :

mir (0.1.4+14.04.20140204-0ubuntu1) trusty; urgency=medium

Changed in mir (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers