Mir

Surfaces no longer visible at all on Nexus 10

Bug #1271853 reported by Daniel van Vugt on 2014-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Critical
Daniel van Vugt
mir (Ubuntu)
Medium
Unassigned

Bug Description

I'm not sure when this happened, but no client surfaces ever appear on screen on the N10 any more. Even running mir_demo_standalone_ has the same issue -- the screen is cleared successfully (to a colour) but no surfaces are visible.

Meanwhile clients think they're rendering successfully and print "60 FPS".

Related branches

description: updated
Daniel van Vugt (vanvugt) wrote :

Bisected, and my fault...

revno: 1345 [merge]
author: Daniel van Vugt <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Wed 2014-01-22 15:54:11 +0000
message:
  Implement screen rotation in GLRenderer, for platforms which can't do it
  natively in DisplayBuffer. Fixes: https://bugs.launchpad.net/bugs/1203215.

  Approved by Alan Griffiths, PS Jenkins bot, Alexandros Frantzis.

Changed in mir:
status: New → Triaged
Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir/devel at revision None, scheduled for release in mir, milestone Unknown

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

mir (0.1.4+14.04.20140204-0ubuntu1) trusty; urgency=medium

Changed in mir (Ubuntu):
importance: Undecided → Critical
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

Not critical for Ubuntu. As the bug itself never existed outside of the development branch.

Changed in mir (Ubuntu):
importance: Critical → Medium
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers