Mir

The following tests FAILED: 99 - memcheck(unit-tests.PublishedSocketConnector.*) (Failed)

Bug #1236698 reported by Daniel van Vugt on 2013-10-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alan Griffiths
mir (Ubuntu)
High
Unassigned

Bug Description

The following tests FAILED:
  99 - memcheck(unit-tests.PublishedSocketConnector.*) (Failed)

Reproduced locally using:
    valgrind bin/unit-tests

First seen here: https://jenkins.qa.ubuntu.com/job/mir-team-mir-development-branch-saucy-amd64-autolanding/30/console

Related branches

Daniel van Vugt (vanvugt) wrote :

Strangely, this bug goes away using the fix for bug 1236697.

Changed in mir:
status: Triaged → Incomplete
Daniel van Vugt (vanvugt) wrote :

Nope, I was wrong. This bug still remains. Just takes several attempts to reproduce.

Changed in mir:
status: Incomplete → Triaged
assignee: nobody → Alan Griffiths (alan-griffiths)
Alan Griffiths (alan-griffiths) wrote :

I think that this actually started some time ago - but e.g. in -r 1111 the unit-tests executable crashed instead of the test failing (and that apparently wasn't detected by CI).

PS This one is really annoying! It only happens about 1 time in 30 and adding trace information to track the problem hides it completely (so far).

Alan Griffiths (alan-griffiths) wrote :

The problem is in double_disconnection_attempt_throws_exception.

There is a small window between the first disconnect being acknowledged and the server dropping the socket. If the second disconnect is written to the socket during this window then there is no error and no exception thrown. (The test is checking for this exception.)

Changed in mir:
status: Triaged → In Progress
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~mir-team/mir/development-branch at revision None, scheduled for release in mir, milestone Unknown

Changed in mir:
status: In Progress → Fix Committed
tags: added: testsfail
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir at revision 1100.

Changed in mir (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
Timo Jyrinki (timo-jyrinki) wrote :
Changed in mir (Ubuntu):
status: Fix Committed → Fix Released
Changed in mir:
milestone: none → phone-v1-freeze
Changed in mir:
milestone: phone-v1-freeze → 0.0.15
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers