Mir

[regression] Lots of examples/ clients are now crashing (display_state->current_mode == 4294967295)

Bug #1207145 reported by Daniel van Vugt on 2013-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Daniel van Vugt
mir (Ubuntu)
Undecided
Unassigned

Bug Description

As of this morning, many of our demo clients are crashing (SIGSEGV). This includes:
   eglplasma
   egltriangle
   fingerpaint

And they all crash for the same reason:

Program received signal SIGSEGV, Segmentation fault.
0x000000000040216f in mir_eglapp_init (argc=1, argv=0x7fffffffe648,
    width=0x7fffffffde3c, height=0x7fffffffde40)
    at /home/dan/bzr/mir/trunk/examples/eglapp.c:186
186 MirDisplayMode mode = display_state->modes[display_state->current_mode];
(gdb) print display_state->current_mode
$1 = 4294967295

Program received signal SIGSEGV, Segmentation fault.
0x000000000040177c in main (argc=1, argv=0x7fffffffe648)
    at /home/dan/bzr/mir/trunk/examples/fingerpaint.c:298
298 parm.width = dinfo->modes[dinfo->current_mode].horizontal_resolution;
(gdb) print dinfo->current_mode
$1 = 4294967295

Related branches

summary: - Lots of examples/ clients are now crashing (display_state->current_mode
- == 4294967295)
+ [regression] Lots of examples/ clients are now crashing
+ (display_state->current_mode == 4294967295)
Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.0.9

Changed in mir:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.0.8+13.10.20130802-0ubuntu1

---------------
mir (0.0.8+13.10.20130802-0ubuntu1) saucy; urgency=low

  [ Daniel van Vugt ]
  * Fix crashing demo clients, since the introduction of multimonitor.
    (LP: #1207145). (LP: #1207145)
  * tools/install_on_android.sh: Don't upload to/test in Android
    directories. We don't need to now that the phablet images are
    flipped. /tmp is much safer. Also don't hardcode a particular ABI
    (which was wrong). .

  [ Alan Griffiths ]
  * graphics, compositor: Move compositor/buffer_properties.h and
    compositor/graphic_buffer_allocator.h to graphics.
  * graphics, compositor: Move buffer_ipc_packer.h to graphics.
  * graphics/gbm: negate negative error codes returned by drm so they
    can be interpreted by boost.

  [ Alexandros Frantzis ]
  * examples: Add option to specify the display configuration policy to
    use We offer three display configuration policies to all the
    examples that use configurations based on
    mir::example::ServerConfiguration: 1. clone (default) 2. sidebyside
    (outputs are placed side-by-side in the virtual space, in increasing
    connector id order) 3. single (only the first, in connector id
    order, is used).

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 914
 -- Ubuntu daily release <email address hidden> Fri, 02 Aug 2013 00:02:52 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
milestone: none → 0.0.9
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers