if xorg exits too early, lightdm should retry starting xorg without -mir

Bug #1204936 reported by Didier Roche on 2013-07-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released

Bug Description

Case of today:
- initializing xorg with -mir fails on ati, it exits on: [drm] failed to set drm interface version. (see dmesg http://paste.ubuntu.com/5911197/ , Xorg.log http://paste.ubuntu.com/5911199/)
lightdm then:
[+1.41s] DEBUG: Starting X server on Unity compositor
[+1.41s] DEBUG: Using VT 7
[+1.41s] DEBUG: Logging to /var/log/lightdm/x-0.log
[+1.41s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
[+1.41s] DEBUG: Launching X Server
[+1.41s] DEBUG: Launching process 4202: /usr/bin/X -core :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+1.41s] DEBUG: Waiting for ready signal from X server :0
[+1.56s] DEBUG: Process 4202 terminated with signal 6
[+1.56s] DEBUG: X server stopped
[+1.56s] DEBUG: Removing X server authority /var/run/lightdm/root/:0
[+1.56s] DEBUG: Releasing VT 7
[+1.56s] DEBUG: Display server stopped
-> it tried it twice, as you can see on http://paste.ubuntu.com/5911373/.

Shouldn't lightdm tries to start xorg with -mir (it's weird I don't see that on logs, so maybe there is something else…), then fallback to traditional xorg if xorg -mir exited too early?

version installed: https://jenkins.qa.ubuntu.com/job/autopilot-saucy-daily_release/label=autopilot-ati/618/artifact/results/sysinfo/dpkg-l.postsetup

Didier Roche (didrocks) on 2013-07-25
tags: added: entering-saucy
Didier Roche (didrocks) on 2013-07-25
summary: - if unity-system-compositor exits too early, lightdm should retry
- starting xorg without -mir
+ if xorg exits too early, lightdm should retry starting xorg without -mir
Didier Roche (didrocks) on 2013-07-25
description: updated
Robert Ancell (robert-ancell) wrote :

This is solved by making unity-system-compositor depend on XMir. So you can't have the system compositor running without XMir available.

Changed in mir:
status: New → Fix Committed
importance: Undecided → Medium
Changed in mir:
milestone: none → 0.0.9
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers