Mir

unity-system-compositor doesn't start on some ati card (with opensource driver)

Bug #1203070 reported by Didier Roche on 2013-07-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Critical
Chris Halse Rogers
Unity System Compositor
Critical
Unassigned

Bug Description

When trying to start unity-system-compositor:
ERROR:
/build/buildd/mir-0.0.7+13.10.20130719ubuntu.unity.next/src/server/graphics/gbm/gbm_cursor.cpp(46):
Throw in function
mir::graphics::gbm::GBMCursor::GBMBOWrapper::GBMBOWrapper(mir::graphics::gbm::GBMPlatform&)
Dynamic exception type:
boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::runtime_error> >
std::exception::what: failed to create gbm buffer

Chris told: "it's failed to create the hw cursor buffer, and I don't believe that there are any more relevant logs
available."

Related branches

Didier Roche (didrocks) on 2013-07-19
Changed in mir:
importance: Undecided → High
status: New → Confirmed
kevin gunn (kgunn72) on 2013-07-22
Changed in mir:
importance: High → Critical
Chris Gagnon (chris.gagnon) wrote :

Which card is this?

can you attach the output of: lspci -v | grep "VGA compatible"

Didier Roche (didrocks) wrote :

05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] (prog-if 00 [VGA controller])

Daniel van Vugt (vanvugt) wrote :

I think I've got a Cedar card somewhere. I can switch it in if really required.

kevin gunn (kgunn72) wrote :

according to mlankhorst
the particular machine in question was missing power management(pm) firmware
kinda makes sense as hw cursor is probably one the first pieces of accelerated hw to hit in the boot sequence & fail due to missing pm
stand alone X was able to pass because it was falling back to sw cursor

Didier Roche (didrocks) wrote :

relevant dmesg logs:

[ 31.259900] Bluetooth: Core ver 2.16
[ 31.259920] NET: Registered protocol family 31
[ 31.259921] Bluetooth: HCI device and connection manager initialized
[ 31.259927] Bluetooth: HCI socket layer initialized
[ 31.259929] Bluetooth: L2CAP socket layer initialized
[ 31.259933] Bluetooth: SCO socket layer initialized
[ 43.185143] lxcbr0: port 1(veth1UUAK6) entered forwarding state
[ 73.385221] lightdm[4723]: segfault at 3f7 ip b7530a42 sp bfb3db8c error 4 in
 libglib-2.0.so.0.3703.0[b74ee000+102000]
[ 112.612848] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 112.612941] ISO 9660 Extensions: RRIP_1991A

Been trying to reproduce this on a:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos PRO [Radeon HD 7450]

But xmir keeps starting up just fine.

kevin gunn (kgunn72) on 2013-07-25
Changed in mir:
status: Confirmed → Fix Released
Changed in unity-system-compositor:
status: New → Fix Released
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers