Mir

Most tests are silently disabled if libumockdev-dev is missing

Bug #1196987 reported by Alan Griffiths on 2013-07-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Alan Griffiths

Bug Description

Since -r 798, if umockdev is missing cmake "succeeds" but no tests are built by the resulting makefile.

If we're going to allow disabling test generation there should be an explicit option to request it.

Related branches

Daniel van Vugt (vanvugt) wrote :

I don't think we need an explicit option to request tests disabled. Instead we just need to improve the CMakeLists to be smarter, and only disable those tests that need to be disabled.

Changed in mir:
status: New → Confirmed
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :
tags: added: regression-update
Changed in mir:
assignee: nobody → Daniel van Vugt (vanvugt)
Alexandros Frantzis (afrantzis) wrote :

The problem with tests being implicitly disabled because of missing dependencies, is that people probably won't notice. That's especially true if only a small portion of the tests doesn't run. Furthermore, running some, but not all, of the tests gives a false sense of correctness, regardless of whether it is done on purpose or not.

I think it makes sense for tests to be considered a subproject with its own additional dependencies, that either gets built or not as a whole. I prefer being explicit about this, since tests are such an important/core subproject for us. That is, assume that we always want to build the tests, unless being told otherwise explicitly.

Changed in mir:
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in mir:
assignee: nobody → Alan Griffiths (alan-griffiths)
Changed in mir:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.0.6

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
milestone: none → 0.0.6
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers