Mir

android links to EGL extension functions directly

Bug #1189938 reported by Kevin DuBois on 2013-06-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Kevin DuBois

Bug Description

Android links to eglCreateImageKHR and eglTargetTexture2DOES directly instead of obtaining their function pointer address via eglGetProcAddress().

This in turn breaks the saucy/android build as detailed in bug 1190894.

Related branches

Changed in mir:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Even worse... saucy's /usr/lib/arm-linux-gnueabihf/libhybris-egl/libEGL.so.1
is missing the function eglCreateImageKHR

It only has eglDestroyImageKHR. Something is fishy and we can't cross-compile for saucy because of this...
Linking CXX shared library ../../lib/libmirserver.so
../../lib/libmirplatformgraphics.a(buffer.cpp.o): In function `mir::graphics::android::Buffer::bind_to_texture()':
/home/dan/bzr/mir/toy/src/server/graphics/android/buffer.cpp:93: undefined reference to `eglCreateImageKHR'

Daniel van Vugt (vanvugt) wrote :

The missing function eglCreateImageKHR is bug 1190894.

Changed in mir:
importance: High → Low
Daniel van Vugt (vanvugt) wrote :

This bug is low priority AFAIK. The available functions in any libEGL won't change very often. And if your code fails to build or execute then that's as good an error message as any.

Changed in mir:
assignee: Kevin DuBois (kdub) → Daniel van Vugt (vanvugt)
importance: Low → High
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Linked a quick experimental branch so that the build completes. Unfortunately the resulting binaries don't work and many tests fail or hang.

description: updated
Changed in mir:
importance: High → Undecided
Kevin DuBois (kdub) on 2013-06-14
Changed in mir:
importance: Undecided → High
Changed in mir:
assignee: Daniel van Vugt (vanvugt) → Kevin DuBois (kdub)
status: In Progress → Fix Committed
milestone: none → 0.0.4
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers