Server backend (mirplatformgraphics) is not dynamically loadable and switchable

Reported by Daniel van Vugt on 2013-02-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
High
Alan Griffiths

Bug Description

The server backend (mirplatformgraphics) should be dynamically loadable and switchable.

This will be required to support multiple graphics technologies such as:
  - Proprietary graphics drivers
  - Software rendering (bug 1118903)
  - Virtual rendering (like rendering Mir into a window)

All in a single server library binary.

Related branches

lp:~raof/mir/separate-graphics-buffer-and-display
On hold for merging into lp:~mir-team/mir/trunk
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-05-01
Kevin DuBois: Needs Fixing on 2013-05-01
Robert Ancell: Approve on 2013-05-01
lp:~alan-griffiths/mir/configurable-graphicsplatform
Merged into lp:~mir-team/mir/trunk at revision 769
Kevin DuBois: Approve on 2013-06-25
Robert Carr: Approve on 2013-06-24
PS Jenkins bot: Approve (continuous-integration) on 2013-06-21
Changed in mir:
importance: Undecided → High
summary: - Server backend (mirplatformgraphics) should be dynamically loadable and
+ Server backend (mirplatformgraphics) is not dynamically loadable and
switchable
Alan Griffiths (alan-griffiths) wrote :

I've been thinking the same thing ever since it was bundled into one big .so

Changed in mir:
status: New → Confirmed
information type: Proprietary → Public
Changed in mir:
assignee: nobody → Chris Halse Rogers (raof)
status: Confirmed → In Progress
milestone: none → 0.0.3
kevin gunn (kgunn72) on 2013-06-19
Changed in mir:
assignee: Chris Halse Rogers (raof) → Alan Griffiths (alan-griffiths)
Daniel van Vugt (vanvugt) wrote :

I just realized, this activity may require changing some GPL code (libmirserver graphics stuff) to LGPL, or another license... ?

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.0.4

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
milestone: 0.0.3 → 0.0.5
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers