Unable to enter enough characters when login

Bug #900353 reported by Stéphane on 2011-12-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Midori Web Browser
Invalid
Undecided
Unassigned

Bug Description

When using Midori (tested 0.4.1 on windows and linux), it is impossible to enter enough characters required for login on web site.

Example a):
- try to login to this web site: http://www.shv-fsvl.ch/member/login.php?lang=de
 => impossible to give more than 4 characters in field "SHV-Nummer". However for "Passwort" it is ok.

Example b):
- try to login to this web site: http://www.bcv.ch/en/
=> impossible to enter more than 7 characters in field "User ID".

Thank you for any advice.
Best regards.
Stephane

David Gomes (davidgomes) wrote :

That is not a Midori problem, it happens in every browser. What's happening is those textboxes limit the number of digits to enter in their textboxes.

Changed in midori:
status: New → Invalid
Stéphane (stephane-bigler) wrote :

Unfortunately, the answer you gave me is NOT correct.

If you try to enter characters in the textboxes using firefox (on web sites I discribed in the initial bug report), you will observe that there is not limit in the number of digits. But when using Midori, the limit appears. This is why I deeply think, the problem is related to Midori.

Stephane

Changed in midori:
status: Invalid → In Progress
gue5t gue5t (gue5t) wrote :

I see the same result in firefox as in midori: capped form lengths. The website actually sends markup specifying that at most a given number of characters should be allowed in the boxes. For example:

<input type="text" id="bcvnet" size="10" maxlength="8" name="_tai_xsalm_userid" autocomplete="off" accesskey="5"/>

It may be that this markup is not sent for some user-agents, as Dagid Gomes suggests. But regardless, midori is behaving correctly in this case.

David Gomes (davidgomes) wrote :

This bug is invalid Stéphane, I replicated it in all major browsers, and gue5t's quote from the HTML code of the pages proofs it.

Changed in midori:
status: In Progress → Invalid
Stéphane (stephane-bigler) wrote :

Sorry guys, but if you really replicated it on all major browers (as you said), there must be a misunderstanding somewhere.

Let me explain again, using a simple test. Here are the steps to reproduce the problem (done under windows XP this morning):

a1) launch the Midori browser,
b1) connect to www.bcv.ch,
c1) type characters in the login textbox until the no more characters are accepted (I could enter "1234567"),
d1) count how many characters you entered,
e1) => maximum 7 characters.

a2) launch the Firefox browser,
b2) connect to www.bcv.ch,
c2) type characters in the login textbox until the no more characters are accepted (I could enter "12345678"),
d2) count how many characters you entered,
e2) => maximum 8 characters.

You will notice that the limits are different between Midori and Firefox:
- Midori limit is 7 characters,
- Firefox limit is 8 characters.

Moreover, you could double-check the attached print screen. It shows exactly what I am faced to.

Stephane

Changed in midori:
status: Invalid → In Progress
David Gomes (davidgomes) wrote :

Can I have your Midori version? I built mine from source the other day and this is not happening, I can enter till 7 characters.

Dear David,
That's the point!!! So with your fresh Midori built you can enter 7 characters (you're saying "I can enter till 7 characters"), but 8 characters are needed!!!!

Once again:
- with Midori, we are limited to 7 characters (which is WRONG),
- with Firefox, we are limited to 8 characters (which is RIGHT).

Please tell me, if you still can not understand my saying (as it seems to be the case from the beginning).

Cheers.
Stephane

PS: as reported in my initial bug report, I did the test with Midori 0.4.1 under widows and linux.

________________________________________
De : <email address hidden> [<email address hidden>] de la part de David Gomes [<email address hidden>]
Date d'envoi : mardi, 13. décembre 2011 09:12
À : Bigler Stéphane
Objet : [Bug 900353] Re: Unable to enter enough characters when login

Can I have your Midori version? I built mine from source the other day
and this is not happening, I can enter till 7 characters.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/900353

Title:
  Unable to enter enough characters when login

Status in Midori: Webkit Web browser:
  In Progress

Bug description:
  When using Midori (tested 0.4.1 on windows and linux), it is
  impossible to enter enough characters required for login on web site.

  Example a):
  - try to login to this web site: http://www.shv-fsvl.ch/member/login.php?lang=de
   => impossible to give more than 4 characters in field "SHV-Nummer". However for "Passwort" it is ok.

  Example b):
  - try to login to this web site: http://www.bcv.ch/en/
  => impossible to enter more than 7 characters in field "User ID".

  Thank you for any advice.
  Best regards.
  Stephane

To manage notifications about this bug go to:
https://bugs.launchpad.net/midori/+bug/900353/+subscriptions

Alexander Butenko (avb) wrote :

windows version have this issue because it bundles webkit 1.4 untill now. You will need to wait until a release with webkit 1.6.

On linux, if you have webkit 1.6 installed you shouldnt have this issue.

Stéphane (stephane-bigler) wrote :

Dear Alexander,
Have you really tried the short test I gave previously?
If you did try it, could you confirm that you were not limited to 7 characters and were able to enter 8 characters?

By the way, the linux distro I am using is Slitaz. Midori 0.4.2 is packed by Slitaz's dev. When checking to midori depends, webkit is not part of the Midori package. Instead of webkit, libwebkit is used.

Thanks for your feedback.
Stephane

Alexander Butenko (avb) wrote :

i tried http://www.bcv.ch/en/ and it was working just ok.

I remember i had same issue long time ago, thats why i wrote that its related to 1.4.

webkit never comes as a part of midori. It always using webkit from a distro packages. libwebkit in your case.
Only on windows midori ships webkit as a part of its installer as there is no other way there.

Stéphane (stephane-bigler) wrote :

Thanks Alexander.

So now I feel REALLY disappointed. According to answers I got in this bug report:
- David Gomes could not enter more than 7 characters when using fresh built Midori version,
- but Alexander could enter 8 characters.

I just do not understand why both of you have different results for the same test...

Stephane

Alexander Butenko (avb) wrote :

Stephane,

Im really not sure you understood what i wrote.

> On linux, if you have webkit 1.6 installed you shouldnt have this issue.

Marking as not a bug.

Changed in midori:
status: In Progress → Invalid
Stéphane (stephane-bigler) wrote :

Dear Alexander,
I perfectly understood your explanations. Do not worry about that.

My concern is more about David answers. Firstly he told me it is not a Midori bug, then he wrote that he tested on many browsers and then he answered that he could not enter more than 7 characters. How would you feel with such of contrary/opposite answers? ;-)

Anyway I understand this is not a Midori bug more an incorrect library version usage when building Midori. I will tell Slitaz's dev about this.

And if I may, it would be nice to document this behavior. I know that few Slitaz users are keeping away of Midori because they can not login. And I would not be surprised that this problem touches many more users.

Cheers.
Stephane

Alexander Butenko (avb) wrote :

i feel that David have also 1.4.X or earlier webkit library installed. :) Thats the only explanation.

I googled a bit for slitaz package of 1.6 version and found it here http://mirror.slitaz.org/packages/cooking/libwebkit-1.6.1.tazpkg

try it and i believe it will resolve your issue.

Stéphane (stephane-bigler) wrote :

Dear all,
Just wanna to confirm that everything works well now.

If anyone is wondering how to use Midori under slitaz, check this out: http://forum.slitaz.org/topic/can-not-login-to-different-web-site?replies=7#post-474

Once again thank you for your help.
Cheers.
Stephane

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions