Midori: Webkit Web browser

Chinese characters appear as blocks

Reported by Wylmer Wang on 2011-03-08
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Midori
Undecided
Jendrik Seipp
RedNotebook
High
Jendrik Seipp

Bug Description

When Chinese characters are entered in the edit area and click Preview, all of them will turn into blocks. The system is Windows 7 sp1, Locale is Chinese simplified, the app version is 1.1.2, portable version. Another user also reported similar problem. I'm not sure about his program version and operating system.

Also the Preference menu item has no effect at all. When clicked nothing appears.

I wonder if this is due to the font setting, but I can't change this setting, because I can't access the preference. I didn't see any setting about fonts in the configuration file under the program directory either.

Wylmer Wang (wantinghard) wrote :
Jendrik Seipp (jendrikseipp) wrote :

This has been already discussed here: https://sourceforge.net/apps/phpbb/rednotebook/viewtopic.php?f=3&t=163
Thanks for taking the discussion to launchpad, however.

As you see, this issue is webkit related and cannot be fixed in RedNotebook itself. It would be interesting to know if the fonts work under Linux or which webkit version is needed to display the Chinese text. Can anyone provide such info?

Changed in rednotebook:
status: New → Incomplete
Gary (garywang) wrote :

With the version 1.1.3, and after manually adding "useWebkit=0" in the configuration.cfg file, the "Preview" can display both Simplified and Traditional Chinese properly.

But still the "Tags" in Chinese in the "Clouds" on the left section display as blank squares.

Wylmer Wang (wantinghard) wrote :

Actually I haven't used this software before, so I don't quite know its settings and how it renders text. The question is, why browsers like chrome don't have this problem? I don't think webkit lack the ability to render Chinese fonts correctly.
Can the default encoding in webkit be set to gb2312, which is the common setting in windows programs? Or can the default render font be set to a Chinese font, like Microsoft Yahei? Maybe these adjust will solve this problem.

Jendrik Seipp (jendrikseipp) wrote :

I still think this is a webkit related bug. Maybe someone can try to file a bug at the webkit or midori (a webkit browser) bugtracker providing them with the exported RedNotebook HTML file. It would be nice if you could link the bugreport here.

It would also be nice to have an overview on which Linux and Windows versions the Chinese fonts work. Does anyone have such info?

Jendrik Seipp (jendrikseipp) wrote :

Can someone please provide an exported HTML file (which is not displayed correctly in RedNotebook)?

Gary (garywang) wrote :

As I said in my previous post: the "Preview" can display both Simplified and Traditional Chinese properly for me now, with the "useWebkit=0". Only the "Tags" in Chinese in the "Clouds" on the left section display as blank squares, which is not what this bug is talking about.

So please 英华 upload your exported HTML for debugging please.

Hi 英华,
Jendrik Seipp is asking for an exported HTML. Please provide one, on https://bugs.launchpad.net/rednotebook/+bug/731273?comments=all ?
are you from china?

> Date: Wed, 9 Mar 2011 01:33:04 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 731273] Re: Chinese characters appear as blocks
>
> Actually I haven't used this software before, so I don't quite know its settings and how it renders text. The question is, why browsers like chrome don't have this problem? I don't think webkit lack the ability to render Chinese fonts correctly.
> Can the default encoding in webkit be set to gb2312, which is the common setting in windows programs? Or can the default render font be set to a Chinese font, like Microsoft Yahei? Maybe these adjust will solve this problem.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/731273
>
> Title:
> Chinese characters appear as blocks
>
> Status in RedNotebook - A Desktop Journal:
> Incomplete
>
> Bug description:
> When Chinese characters are entered in the edit area and click
> Preview, all of them will turn into blocks. The system is Windows 7
> sp1, Locale is Chinese simplified, the app version is 1.1.2, portable
> version. Another user also reported similar problem. I'm not sure
> about his program version and operating system.
>
> Also the Preference menu item has no effect at all. When clicked
> nothing appears.
>
> I wonder if this is due to the font setting, but I can't change this
> setting, because I can't access the preference. I didn't see any
> setting about fonts in the configuration file under the program
> directory either.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/rednotebook/+bug/731273/+subscribe

Gary (garywang) wrote :

How do I edit/delete my comments?

If I cannot, moderator please delete the comment #8, and this one, #9, as they are duplicate ones. thanks.

Jendrik Seipp (jendrikseipp) wrote :

Comments cannot be edited.

Can you set useWebkit to 1 and upload an HTML file?

Gary (garywang) wrote :

I have attached an HTML with the "useWebkit=0" setup.

Gary (garywang) wrote :

Sorry, it is "useWebkit=1" setup.

Yes, I'm from China, but I don't use it, just reported the bug for Chinese users...

Well Ok, I will download the software and upload a xml file later.

Wylmer Wang----------------------------------------------------------Freedom is universal.

Wylmer Wang (wantinghard) wrote :

Do I still need to upload a file?
Yes, set usewebkit=0 solves the problem.
Seems that using webkit or not does not affect the exported file? HTML file exported with both settings displayed well in my Chrome browser.
As supplement to Gary, here's the file exported with usewebkit=0.

Changed in rednotebook:
status: Incomplete → Triaged
assignee: nobody → Jendrik Seipp (jendrikseipp)
importance: Undecided → High
Jendrik Seipp (jendrikseipp) wrote :

I have opened the linked file from comment #11 in midori 0.3.6 on windows and it shows the Chinese characters as blocks, so I added midori to the list of affected projects. Maybe someone there knows if the bug is already fixed upstream in WebkitGTK and which dlls have to be updated.

I think this issue must have been fixed upstream, because it doesn't occur on my Linux machine.

Changed in rednotebook:
status: Triaged → Confirmed
Jendrik Seipp (jendrikseipp) wrote :

I just downloaded a new set of webkit and PyGTK dlls from http://opensourcepack.blogspot.com/2011/01/conservative-all-in-one-pygtk-installer.html (rev3) and the above linked file is rendered correctly. It seems the issue can be solved by updating the dlls. I will try to do so as soon as time allows.

Changed in rednotebook:
status: Confirmed → Triaged
Jendrik Seipp (jendrikseipp) wrote :

I have created a new installer that should fix the problem here http://dl.dropbox.com/u/4780737/rednotebook-1.1.7b1.exe

Can you try it and report if it solves the issue, please?

Changed in rednotebook:
status: Triaged → Fix Released

I have tested. Yes the problem is solved. Now the "Tags" in Chinese are displayed properly.
Thanks for your effort.

> Date: Mon, 11 Jul 2011 14:11:44 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 731273] Re: Chinese characters appear as blocks
>
> I have created a new installer that should fix the problem here
> http://dl.dropbox.com/u/4780737/rednotebook-1.1.7b1.exe
>
> Can you try it and report if it solves the issue, please?
>
> ** Changed in: rednotebook
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/731273
>
> Title:
> Chinese characters appear as blocks
>
> Status in Midori: Webkit Web browser:
> New
> Status in RedNotebook - A Desktop Journal:
> Fix Released
>
> Bug description:
> When Chinese characters are entered in the edit area and click
> Preview, all of them will turn into blocks. The system is Windows 7
> sp1, Locale is Chinese simplified, the app version is 1.1.2, portable
> version. Another user also reported similar problem. I'm not sure
> about his program version and operating system.
>
> Also the Preference menu item has no effect at all. When clicked
> nothing appears.
>
> I wonder if this is due to the font setting, but I can't change this
> setting, because I can't access the preference. I didn't see any
> setting about fonts in the configuration file under the program
> directory either.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/midori/+bug/731273/+subscriptions

tags: added: encoding
stanley sun (shunli-sun) wrote :

OS: Windows XP SP3 32bit

[Steps]
1. Install 'rednotebook-1.6.1.exe' in OS
2. Launch rednotebook app
3. Enter some Chinese characters in Edit status
4. Switch to Preview status

[Actual Result]
The Chinese characters display as blank square. Please refer to 'Screenshot.zip'

[Comment]
I read the comments above. This bug should has been fixed yet. Is this a regression bug?

Changed in midori:
assignee: nobody → Jendrik Seipp (jendrikseipp)
stanley sun (shunli-sun) wrote :

BTW, I download 'rednotebook-1.4.0.exe' and it can display Chinese characters correctly. 1.5 version appears the same issue as this bug. I hope this info is helpful.

Jendrik Seipp (jendrikseipp) wrote :

Yes, that's a regression introduced when I updated the Windows webkitgtk libs. Thanks for the additional info, I'll see if I can find newer webkitgtk dlls for windows anywhere, but those are hard to find.

Jendrik Seipp (jendrikseipp) wrote :

Probably the same bug is tracked here: https://bugs.launchpad.net/rednotebook/+bug/1027357

tags: added: win32
Cody Garver (codygarver) on 2013-04-20
Changed in midori:
status: New → Incomplete
Robert Shiplett (grshiplett) wrote :

why is the Tag Cloud problem considered a different bug ?

Robert Shiplett (grshiplett) wrote :

setting "useWebkit=0" into the CFG file has had no effect (neither in default file nor user file.)

Why would the app be relying on library defaults in some DLL rather than setting the value based on a user choice?

It is even not difficult to query whether a given font will display a given character ... ( I have just such an app that I wrote for Win/Mac/Linux so a user can make such font choices.)

tags: added: font
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers