[AppMenu] don't show "customize toolbar"

Bug #699933 reported by Daniel Fore
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Midori Web Browser
Fix Released
Low
Daniel Fore

Bug Description

The entry "customize toolbar" created by the toolbar editor extension should appear in the toolbar context menu instead of the AppMenu.

Daniel Fore (danrabbit)
Changed in midori:
importance: Undecided → Low
Daniel Fore (danrabbit)
tags: added: bitesize
Revision history for this message
Christian Dywan (kalikiana) wrote :

A function may need to be added to MidoriBrowser so the extension can do this.

Changed in midori:
status: New → Confirmed
Revision history for this message
Daniel Fore (danrabbit) wrote :

ah okay, maybe not so bitesize. pulling the tag.

tags: removed: bitesize
Michael Moroni (airon90)
tags: added: appmenu toolbar
Revision history for this message
Tomasz Szatkowski (szatkus) wrote :

I added new signal ("populate-toolbar-menu") and left "customize toolbar" item in tools. Now this option is both in tools menu and toolbar context menu, but I shortened the second version to "customize".

Revision history for this message
Christian Dywan (kalikiana) wrote :

The menu item needs to say "Customise..." with periods to indicate that it shows a dialogue. Also I think it needs a separator, otherwise I can't tell that it's not another check mark.

Part of the issue is not addressed: it should no longer show up in the tools/ app menu. This may however be slightly confusing to upgrading users, not entirely sure if that's an issue.

In terms of code, please respect the coding style used in the toolbar editor, ie. tabs rather than spaces. Looking at the style of the function is generally good measure if you're unsure.

Changed in midori:
assignee: nobody → Tomasz Szatkowski (szatkus)
status: Confirmed → In Progress
Revision history for this message
Tomasz Szatkowski (szatkus) wrote :

Done.

Revision history for this message
Christian Dywan (kalikiana) wrote :

Very nice, thanks a lot.

Changed in midori:
status: In Progress → Fix Committed
Changed in midori:
status: Fix Committed → Fix Released
Revision history for this message
Daniel Fore (danrabbit) wrote :

Reopening this report since it was originally about removing the entry from the AppMenu.

Changed in midori:
status: Fix Released → New
assignee: Tomasz Szatkowski (szatkus) → nobody
Daniel Fore (danrabbit)
Changed in midori:
assignee: nobody → Daniel Fore (danrabbit)
status: New → In Progress
Revision history for this message
Christian Dywan (kalikiana) wrote :

Indeed, we have the context menu, the app menu item can go away.

Revision history for this message
Christian Dywan (kalikiana) wrote :

Thanks for the fix! Committed.

Changed in midori:
status: In Progress → Fix Committed
Changed in midori:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints