Midori: Webkit Web browser

Missing menus in Midori

Reported by Daniel Weinstein on 2010-08-08
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Wishlist
Unassigned
DBus Menu
Undecided
Unassigned
Midori
Undecided
Unassigned
appmenu-gtk (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: indicator-application

Midori usually has the menus :
File Edit View Go Bookmarks Tools Help

With appmenu the Bookmark and Tools menu's are missing. So the menubar shows up as:
File Edit View Go Help

Related branches

Omer Akram (om26er) on 2010-08-08
affects: indicator-application (Ubuntu) → appmenu-gtk (Ubuntu)

I noticed that you put an extra space between "Go" and "Help" does that
mean that the menus are there, but don't have a text entry for them, or
they don't exist anywhere?

I'm sorry I haven't answered in so long

Don't read anything into the space between Go and Help, that was just a typo.

I obviously , the menus exist somewhere, since they reapear inthe window when appmenu is disabled, but they are no in any way accessable or visable in appmenu.

The fact thatthis happens with Midori, indicates that there is somenthing, that could be a deeper problem, which potentially could effect many apps.

tags: added: midori
Wadelius (wadelius) wrote :

I have almost the same problem on Ubuntu 10.04 with Midori 0.2.7. I have "File Edit View Go Tools Windows Help". Only Bookmarks is missing for me. I have tried this with swedish and english settings, only the Bookmarks menu is missing.

Any ideas on what can cause this?

Cody Russell (bratsche) wrote :

I'm surprised you're seeing as many menus as you are. I'm seeing: "File Edit View Go Help Dummy".

I'm missing Bookmarks, Tools, and Window menuitems. And yes, I'm seeing Dummy as a menuitem I probably shouldn't be seeing, although that gives me access to all the menuitems that should be under Bookmarks, Tools, and Window.

Midori is doing some unusual things that other apps aren't doing. The way it's building its dynamic menus is something that appmenu-gtk isn't able to catch right now. Since Midori is not the default browser for Ubuntu Netbook Edition, I'm afraid the priority for fixing this is extremely low.

Changed in appmenu-gtk (Ubuntu):
importance: Undecided → Wishlist
Changed in appmenu-gtk:
importance: Undecided → Wishlist
Joan Jimenez (joajimenez) wrote :

I'm having this same problem but in Comix 4.0.4.

I can't see the "Open Recent" menu under UNE 10.10. I'm ataching an screenshot. When I use Gnome both Comix and Midori work well.

I made a bug report also in SourceForge:

https://sourceforge.net/tracker/?func=detail&aid=3066296&group_id=146377&atid=764985

2cute4u (mistywillows) wrote :

Cody: i don't get how not being the default browser makes the priority low.

1) People don't always use the default browser, unless you plan on removing pagkages that don't work with appmenu from the repositories., then its a bug that need to be addressed.

2) Appmenu isn't only used by people using netbooks, I have been using it, in desktop ubuntu on my 27 inch iMac.

3) This bug isn't isolated to midori, but can show up any number of other programs, like it did in Comix.

4) It makes ubuntu look bad.

As long as this bug persists, appmenu is fundamentally broken. In my opinion, this bug should be elevated from wishlist to critial.

Changed in appmenu-gtk:
status: New → Incomplete
status: Incomplete → Confirmed
Changed in appmenu-gtk (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed

A criticla bug is one that affects every user in a way that prevents
them from using the software. This bug by definition affects a small
percentage of users. Low or wishlist are appropriate importances.

Mark

Allcolor-g (allcolor) wrote :

Well it's not critical but why isn't there an easy way to blacklist applications, that could help a lot of users when things don't work properly.

gnome-globalmenu had less problems, but it seems it's not available in maverick for now.

vcap (vcappe) wrote :

Wadelius, above, said he only miss the Bookmarks menu, but there was no such menu in midori 0.2.7, so he didn't actually miss anything. (the Bookmarks menu was back in 0.2.8).

2cute4u (mistywillows) wrote :

Wadelius never said it was working in 0.2.8, when he wrote the comment 0.2.7 was the latest release. And he was using ubuntu 10.4 which doesn't even have appmenu, so his comment possibly was about gnome2globalmenu instead.

using ubuntu 10.10, with both midori 0.2.4, and 0.2.8, I got
File Edit View Go Help

Alex Launi (alexlauni) wrote :

Is this still a problem on Natty with the new dbusmenu?

Changed in dbusmenu:
status: New → Incomplete
tags: added: parser
Omer Akram (om26er) wrote :

yes, is still an issue.

Changed in dbusmenu:
status: Incomplete → Confirmed
Kalle Valo (kvalo) wrote :

I'm marking as triaged for appmenu. But how is dbusmenu involved here? Should I just remove it?

Changed in appmenu-gtk:
status: Confirmed → Triaged
Changed in appmenu-gtk (Ubuntu):
status: Confirmed → Triaged
Kalle Valo (kvalo) on 2011-02-21
Changed in dbusmenu:
status: Confirmed → Triaged
Michael Moroni (airon90) wrote :

Now with 11.04 under Unity (2D, because my graphic card doesn't support OpenGL) there is no menu in the upper panel...

Changed in midori:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

is that an issue under unity-3d as well?

Sebastien Bacher (seb128) wrote :

seems midory on natty just has no menu, that's not an indicator-appmenu issue, they put the menu under an icon in the iconsbar not as a standard menu in the ui

Michael Moroni (airon90) wrote :

Sebastien Bacher wrote on 2011-05-02:
seems midory on natty just has no menu, that's not an indicator-appmenu issue, they put the menu under an icon in the iconsbar not as a standard menu in the ui

No: by default menubar is not activated. Rightclick on the navbar and you can activate it. So, if menubar is activated, indicator-appmenu should display menus correctly.

papukaija (papukaija) on 2011-08-04
tags: removed: midori
Bennett Kanuka (bkanuka) wrote :

Following up after upgrading to Midori 0.4.0: The menu is still not displayed in indicator-appmenu.

The menubar is hidden by default and right-clicking on the menu button and checking menubar shows the menubar IN midori and not in the indicator-appmenu.

dino99 (9d9) wrote :

Cant get the menu on Oneiric i386 b1 logged as gnome-classic, only have the icon menu on top right and cant activate top menu with right clicking.

Pavel Fischer (rubbiroid) wrote :

Have same issue, but with my own GTK2 Application.
I have a dynamic menu items. They will be added and removed many times in runtime. Global menu filtern items, that haven't an action or sub menu. So, if i add some child menu items, they will be no visible in global menu.

Changed in midori:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released

Excellent, now we have to remove Midori from the blacklist of dbusmenu/appmenu-gtk because at the moment the menu is displayed in the window to workaround this bug.

Christian Dywan (kalikiana) wrote :

There is no need, Midori already uses a different internal name. By the way this mechanism is extremely evil for innocent developers who have no way of figuring out that the blacklist exists in the first place without even a warning.

I agree, as an end user of Midori I had to deal with the same problem when I wondered why Midori displays its menu in the window, and discovered that specific binary file names are blocked in the source of appmenu, so I renamed my /usr/bin/midori to /usr/bin/midori-bin which brought me to this bug here.
Actually I don't understand the reason for the hardcoded blacklist because the developer or user of an application that does not work with the appmenu just needs to set UBUNTU_MENUPROXY to 0.

dino99 (9d9) on 2013-04-26
tags: added: raring saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.