Change default font from "Sans" to "Times New Roman"

Bug #1205716 reported by Zlip on 2013-07-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Midori Web Browser
Fix Released
Wishlist
Unassigned

Bug Description

As mentioned in the title, it is about changing the default font of midori on windows platform, default font make text looks ugly on Windows, I suggest making default font on Windows platform same used as Chrome and Firefox browser.

Firefox Nightly 25 default:
Fonts for "Westren"
Proportional: Serif (16)
Serif: Times New Roman
Sans-serif: Arial
Monospace: Courier New (13)

With selection of "Allow sites to use their own fonts except my settings".

Chromium 30 default:
Standard Font: Times New Roman (16)
Serif font: Times New Roman (16)
Sans-serif: Arial (16)
Fixed-width: Courier New

I personally prefer Firefox fonts because it really makes Web looks amazing a different + it has direct write hardware acceleration for texts while Chromium does not. But follow anyone in midori for Windows platform.

Platform details:
OS: Windows 7 Professional 64-bit Service Pack 1 (updated)
DirectX: Latest with Platform update and IE11 developer preview installed, so few DirectX 11.1 API if matters
Resolution: 1680*1050
GPU: nvidia GTX 460 1 GB with 314.22 WHQL driver

Attaching Firefox default picture

Related branches

Zlip (zlip-792) wrote :
Donte Greene (flykidd) on 2013-09-15
Changed in midori:
importance: Undecided → Wishlist
Christian Dywan (kalikiana) wrote :

Makes sense to me - Sans as a default was mostly inherited from Linux where the situation is different.

Changed in midori:
status: New → Confirmed
tags: added: font
Changed in midori:
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2013-11-19
Changed in midori:
milestone: none → 0.5.6
Changed in midori:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions