Close Tab shortcut just opens "New Tab" Page

Bug #1022337 reported by Keith Adair on 2012-07-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Granite
Fix Released
High
Unassigned
Midori Web Browser
Fix Released
Undecided
Unassigned

Bug Description

When I hit CTRL-W (or what ever my close tab shortcut is), the tab stays open, and a new tab page is opened.

Keith Adair (kjzz12) wrote :

I just tested this in midori-gtk3 and that works fine. ONLY midori-granite is affected.

tags: removed: gtk3
Keith Adair (kjzz12) wrote :

libgranite0:
  Installed: 0.2-0~r298+pkg30~precise1
  Candidate: 0.2-0~r298+pkg30~precise1
  Version table:
 *** 0.2-0~r298+pkg30~precise1 0
        500 http://ppa.launchpad.net/elementary-os/daily/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     0.2-0~r290+pkg29~precise1 0
        500 http://ppa.launchpad.net/midori/midori-dev/ubuntu/ precise/main i386 Packages
     0.2~r298-0+pkg30~precise1 0
        500 http://ppa.launchpad.net/sgringwe/beatbox/ubuntu/ precise/main i386 Packages
     0.1.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages

tags: added: granite
removed: midori-granite
Changed in midori:
status: New → Confirmed
Christian Dywan (kalikiana) wrote :

tab.page is null when the tab has contents
    → closing problem in Midori because it checks current.page != null

summary: - Close Tab keyboard shortcut just opens the "New Tab" Page
+ Close Tab shortcut just opens "New Tab" Page
Changed in granite:
importance: Undecided → High
milestone: none → luna-beta1
Christian Dywan (kalikiana) wrote :

Midori's part of this is solved, by changing how we close tabs.

There's still cases where no tab-removed is emitted from Granite so Trash and session saving don't work.

Changed in midori:
status: Confirmed → Fix Committed
Changed in granite:
status: New → Confirmed
Christian Dywan (kalikiana) wrote :

I realize bug 1021565 is more appropriate for the remaining problem.

Changed in granite:
status: Confirmed → Fix Committed
Changed in midori:
status: Fix Committed → Fix Released
Changed in granite:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers