Closing tab doesn't actually close it.

Bug #1021565 reported by Daniel Fore on 2012-07-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
High
Unassigned
Midori Web Browser
Fix Released
Undecided
Unassigned

Bug Description

Using Granite

It appears that when tabs are closed, some signal isn't being sent back to Midori. The tabs aren't actually being closed, the tab is just hidden.

If I close a few tabs, close Midori and re-open it, all the tabs I closed will re-appear. This can lead to Midori starting up with 100's of tabs.

What's more annoying is closing a tab with video or audio, I can still hear the content continuing to play in the background.

Daniel Fore (danrabbit) on 2012-07-08
summary: - Opens tabs that were closed on next launch
+ Closing tab doesn't actually close it.
description: updated
Christian Dywan (kalikiana) wrote :

Granite doesn't always emit tab-removed, so depending on how you close it, Midori doesn't take notice that you did.

Changed in granite:
status: New → Confirmed
importance: Undecided → High
milestone: none → luna-beta1
Changed in midori:
status: New → Confirmed
status: Confirmed → Fix Committed
Tom Beckmann (tombeckmann) wrote :

It is emitted when clicking the close button or pressing Ctrl+W. Do I miss a way to close a tab?
I added a print to granite-demo.
Are you sure, you're returning TRUE from the connected handler? Otherwise, the tab won't be removed from the notebook.

Christian Dywan (kalikiana) wrote :

Closing with close buttons works.
If Midori calls remove_tab() the signal is never emitted.

This is tab-removed in Midori:

view = tab.get_page()
/* internal Midori signal that the tab was removed */
view.destroy()
return true

Tom Beckmann (tombeckmann) wrote :

Should be fixed now if I'm not mistaken.

Changed in granite:
status: Confirmed → Fix Committed
Changed in midori:
status: Fix Committed → Fix Released

No this bug isn't fixed. If i close a tab the sound continues playing in the background.
Another annoying bug is that HTML5 videos on youtube only play the sound but not the video itself.

PS : I'm using the latest midori version of elementary luna beta 1.

Cody Garver (codygarver) wrote :

This version has not yet been made available to Luna. That's something I need to work on with Christian.

Christian Dywan (kalikiana) wrote :

Just FYI, the fixed version is in Luna beta builds.

Changed in granite:
status: Fix Committed → Fix Released

I'm still affected by this bug. I'm using Midori 0.4.8 from elementary OS PPA.

fabiodan (fabiosantosart) wrote :

This bug is present in ElementaryOS Luna, and it's so annoying.

I like midori's ability to restore previously open tabs, but yesterday I watched a few videos and they will haunt me forever. They have been restored in every browser session I started since then. And if I close their tabs without pausing the video first, they won't shut up, and I get to listen to 6 40-minute long videos of talks at the same time.

It would be hilarious if I wasn't trying to get stuff done.

This browser is amazing and lightweight and super easy to use, but I'll have to use firefox until this is fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers