Midori: Webkit Web browser

Don't listen to GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED

Reported by Arturo Torres Sánchez on 2012-06-12
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Gala
High
Unassigned
Midori
Undecided
Unassigned

Bug Description

I'm using Midori 0.4.6 (with GTK+3), Gala 0.1 (rev 95), and Ubuntu 12.04.

When I maximize a Midori window, the titlebar is lost, leaving just the toolbar, the tabbar (although I've disabled it) and the content. However, this only happens with Midori and no other maximized window, and only under Gala and not under Compiz.

Gala should ignore this request until such a time that it either provides an unmaximize method or (preferably) detects a Shell that provides an unmaximize method.

Related branches

This also happens just with the GTK+3 version of Midori. The GTK+2 version has the titlebar as expected.

Christian Dywan (kalikiana) wrote :

Midori uses gtk_window_set_hide_titlebar_when_maximized, the same as Epiphany. To quote the documentation:

 This is useful for windows that don't convey any information other
 than the application name in the titlebar, to put the available
 screen space to better use. If the underlying window system does not
 support the request, the setting will not have any effect.

In window manager terms, it sets _GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED. So this is a bug in the window manager, or the way the its setup in the desktop environment. Not Midori.

Changed in midori:
status: New → Invalid
tags: added: gtk3
Daniel Fore (danrabbit) wrote :

updated the bug title and desctription to reflect a course of action for Gala

summary: - Midori loses its titlebar when maximized (not fullscreen)
+ Don't listen to GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED
description: updated
Changed in gala:
status: New → Confirmed
importance: Undecided → High
milestone: none → luna-beta1
David Hsu (illusionmist62442) wrote :

Happens with Google Chrome as well, same cause?
Been wondering since day one with Gala and it never occurred to me that a bug should be filed... XD

But with Chromium it doesn't happen. At least not in my machine.

On 6/15/12, David Hsu <email address hidden> wrote:
> Happens with Google Chrome as well, same cause?
> Been wondering since day one with Gala and it never occurred to me that a
> bug should be filed... XD
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1012311
>
> Title:
> Don't listen to GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED
>
> Status in Gala Window Manager:
> Confirmed
> Status in Midori: Webkit Web browser:
> Invalid
>
> Bug description:
> I'm using Midori 0.4.6 (with GTK+3), Gala 0.1 (rev 95), and Ubuntu
> 12.04.
>
> When I maximize a Midori window, the titlebar is lost, leaving just
> the toolbar, the tabbar (although I've disabled it) and the content.
> However, this only happens with Midori and no other maximized window,
> and only under Gala and not under Compiz.
>
> Gala should ignore this request until such a time that it either
> provides an unmaximize method or (preferably) detects a Shell that
> provides an unmaximize method.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gala/+bug/1012311/+subscriptions
>

--
—Arturo Torres Sánchez

David Hsu (illusionmist62442) wrote :

Yeah the stable version (18) in the Ubuntu repository doesn't have that change;
I'm using dev channel Chrome (21) though, also checked with latest Chromium and it's indeed hidden.

Brendan William (mamemame187) wrote :

a dconf option would be nice

Brendan William (mamemame187) wrote :

for gala i mean

Changed in gala:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers