sudo snap install microstack error

Bug #1900113 reported by NAM EUNSEONG
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MicroStack
Fix Released
High
Dmitrii Shcherbakov

Bug Description

2020-10-16
After update in 10.16 - 2020 , I install microstack with

$sudo snap install microstack --devmode --beta
error: cannot perform the following tasks:
- Start snap "microstack" (215) services ([start snap.microstack.load-modules.service] failed with exit status 1: Job for snap.microstack.load-modules.service failed because the control process exited with error code.
See "systemctl status snap.microstack.load-modules.service" and "journalctl -xe" for details.
)

$sudo snap install microstack --classic --beta
error: cannot perform the following tasks:
- Start snap "microstack" (215) services ([start snap.microstack.load-modules.service] failed with exit status 1: Job for snap.microstack.load-modules.service failed because the control process exited with error code.
See "systemctl status snap.microstack.load-modules.service" and "journalctl -xe" for details.
)

Either options give same error.
Sometimes, above command works and sometimes not. Could you tell me why this happen and help me with microstack isntallation?

Revision history for this message
Dmitrii Shcherbakov (dmitriis) wrote :

Hello Nam,

Thank you for the bug report.

Without having the journal log and knowing that the issue is intermittent, I can only guess that this is due to the lack of extra kernel modules available on the system where things break.

$ dpkg -S /lib/modules/4.15.0-122-generic/kernel/drivers/pci/pci-stub.ko
linux-modules-extra-4.15.0-122-generic: /lib/modules/4.15.0-122-generic/kernel/drivers/pci/pci-stub.ko

$ dpkg -l | grep modules-extra | grep 122
ii linux-modules-extra-4.15.0-122-generic 4.15.0-122.124 amd64 Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP

As a workaround, you could install this package but the real fix would be for us to drop this module.

I found that it is no longer supported by libvirt either way (presumably in favor of VFIO):
https://github.com/libvirt/libvirt/commit/b8e7e9be9a2168648d16417e2442e322a17c44c7

Changed in microstack:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Dmitrii Shcherbakov (dmitriis)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to microstack (master)

Fix proposed to branch: master
Review: https://review.opendev.org/759044

Changed in microstack:
status: Triaged → In Progress
Revision history for this message
NAM EUNSEONG (nesllewr) wrote :

I retry to install microstack again and get these logs!

~$ systemctl status snap.microstack.load-modules.service
● snap.microstack.load-modules.service
   Loaded: not-found (Reason: No such file or directory)
   Active: failed (Result: exit-code) since Wed 2020-10-21 15:20:15 UTC; 52s ago
 Main PID: 20032 (code=exited, status=1/FAILURE)

Oct 21 15:20:15 ip-123-34-56-789 systemd[1]: Starting Service for snap application microstack.load-modOct 21 15:20:15 ip-172-31-32-231 microstack.load-modules[20032]: + modprobe -a vhost vhost-net vhost-sOct 21 15:20:15 ip-172-31-32-231 microstack.load-modules[20032]: modprobe: WARNING: Module pci-stub noOct 21 15:20:15 ip-172-31-32-231 systemd[1]: snap.microstack.load-modules.service: Main process exitedOct 21 15:20:15 ip-172-31-32-231 systemd[1]: snap.microstack.load-modules.service: Failed with result
Oct 21 15:20:15 ip-123-34-56-789 systemd[1]: Failed to start Service for snap application microstack.llines 1-11/11 (END)...skipping...
● snap.microstack.load-modules.service
   Loaded: not-found (Reason: No such file or directory)
   Active: failed (Result: exit-code) since Wed 2020-10-21 15:20:15 UTC; 52s ago
 Main PID: 20032 (code=exited, status=1/FAILURE)

Oct 21 15:20:15 ip-123-34-56-789 systemd[1]: Starting Service for snap application microstack.load-modules...
Oct 21 15:20:15 ip-123-34-56-789 microstack.load-modules[20032]: + modprobe -a vhost vhost-net vhost-scsi vhost-vsock pci-stub vfio nbd dm-mod dm-thin-pool dm-snapshot iscsi-tcp target-core-mod
Oct 21 15:20:15 ip-123-34-56-789 microstack.load-modules[20032]: modprobe: WARNING: Module pci-stub not found in directory /lib/modules/5.3.0-1035-aws
Oct 21 15:20:15 ip-123-34-56-789 systemd[1]: snap.microstack.load-modules.service: Main process exited, code=exited, status=1/FAILURE
Oct 21 15:20:15 ip-123-34-56-789 systemd[1]: snap.microstack.load-modules.service: Failed with result 'exit-code'.
Oct 21 15:20:15 ip-123-34-56-789 systemd[1]: Failed to start Service for snap application microstack.load-modules.

And I type the command suggested, and the result it:
$ dpkg -S /lib/modules/4.15.0-122-generic/kernel/drivers/pci/pci-stub.ko
dpkg-query: no path found matching pattern /lib/modules/4.15.0-122-generic/kernel/drivers/pci/pci-stub.ko

$ dpkg -l | grep modules-extra | grep 122
# Nothing came out after this command

Before October, I use the same aws instance and install microstack successfully since May 2020. Is microstack changed with requirements ( so that I need to check other options )?
I also tried to install microstack in virtual box and VMware with ubuntu image 18.04(ubuntu-18.04.4-desktop-amd64.iso), and it failed with same problem above. Could you please help me with this ?

Revision history for this message
Dmitrii Shcherbakov (dmitriis) wrote :

Until the fix is merged you can simply install the missing package to get the needed kernel module:

sudo apt update && sudo apt install linux-modules-extra-`uname -r`

The dpkg commands above merely list the current host state.

Revision history for this message
Walt Boring (walter-boring) wrote :

I have the same problem on a fresh focal vm.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to microstack (master)

Reviewed: https://review.opendev.org/759044
Committed: https://git.openstack.org/cgit/x/microstack/commit/?id=c19525476dee05f31ecf0567c80047bd578f3c2c
Submitter: Zuul
Branch: master

commit c19525476dee05f31ecf0567c80047bd578f3c2c
Author: Dmitrii Shcherbakov <email address hidden>
Date: Wed Oct 21 16:07:17 2020 +0300

    Drop pci-stub from the load-modules service

    pci-stub is available on Ubuntu from modules-extra kernel packages,
    however, those are not always installed.

    By the looks of it, this module is no longer supported by Libvirt either
    (presumably in favor of VFIO):
    https://github.com/libvirt/libvirt/commit/b8e7e9be9a2168648d16417e2442e322a17c44c7

    Change-Id: I0db4d43d458893493232e150ae2f5b2bb7e05772
    Closes-Bug: #1900113

Changed in microstack:
status: In Progress → Fix Released
Changed in microstack:
status: Fix Released → Fix Committed
Revision history for this message
Dmitrii Shcherbakov (dmitriis) wrote :

Walt, I checked revision 216 and I believe you are running into the same issue with the pci-stub module so comment #4 still applies.

Revision 217 in the beta and edge channels contains the fix and is available now.

Changed in microstack:
status: Fix Committed → Fix Released
Revision history for this message
Jathin (sjathin) wrote :

2020-12-06

I tried running the following command on a Ubuntu 20.4 VM.

$sudo snap install microstack --devmode --beta

I am still facing the following issue:

microstack@ubuntu:~$ sudo snap install microstack --devmode --beta
error: cannot perform the following tasks:
- Start snap "microstack" (222) services ([start snap.microstack.load-modules.service] failed with exit status 1: Job for snap.microstack.load-modules.service failed because the control process exited with error code.
See "systemctl status snap.microstack.load-modules.service" and "journalctl -xe" for details.
)

microstack@ubuntu:~$ systemctl status snap.microstack.load-modules.service
● snap.microstack.load-modules.service
     Loaded: not-found (Reason: Unit snap.microstack.load-modules.service not found.)
     Active: failed (Result: exit-code) since Sun 2020-12-06 13:48:42 PST; 1min 26s ago
   Main PID: 169075 (code=exited, status=1/FAILURE)

Dec 06 13:48:41 ubuntu systemd[1]: Starting Service for snap application microstack.load-modules...
Dec 06 13:48:42 ubuntu microstack.load-modules[169075]: + modprobe -a vhost vhost-net vhost-scsi vhost-vsock vfio nbd dm-mod dm-thin-poo>
Dec 06 13:48:42 ubuntu microstack.load-modules[169127]: modprobe: ERROR: could not insert 'vhost_vsock': Device or resource busy
Dec 06 13:48:42 ubuntu systemd[1]: snap.microstack.load-modules.service: Main process exited, code=exited, status=1/FAILURE
Dec 06 13:48:42 ubuntu systemd[1]: snap.microstack.load-modules.service: Failed with result 'exit-code'.
Dec 06 13:48:42 ubuntu systemd[1]: Failed to start Service for snap application microstack.load-modules.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers