Cannot Pre-emptively Set ext-network via snap config

Bug #1851521 reported by Pen Gale
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MicroStack
Fix Released
Medium
Unassigned

Bug Description

It should be possible to set ext-cidr and ext-network to something other than the default before microstack.init is run.

In practice, however, this doesn't work. The values can be set ('sudo snap set microstack config.network.ext-network=<foo>'), but the .init script throws an exception.

This is probably because the default values have been written to templates. The .init script should rewrite the templates and restart services before it does anything else.

Revision history for this message
Pen Gale (pengale) wrote :

This issue causes a lockup when I try to test MicroStack using a MicroStack cloud. Because both the top level host and the MicroStack guests are attempting to use the same network, I lose connectivity to the guests. We need to avoid binding br-ex to the network until we've given an operator a chance to fix the network (or do some intelligent discovery and avoid clobbering an existing network on the host.)

Pen Gale (pengale)
Changed in microstack:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Pen Gale (pengale) wrote :
Pen Gale (pengale)
Changed in microstack:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers