with no changes, madgraph now gives keyerror "version" on launch

Bug #1972058 reported by Jack
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
New
Undecided
Unassigned

Bug Description

I've been using madgraph for a few months and it's been working fine, launched it today and got:

Traceback (most recent call last):
  File "mg5_aMC.py", line 148, in <module>
    import madgraph.interface.master_interface as interface
  File "/mnt/c/Users/Jack/OneDrive/Documents/MG5_aMC_v3_3_1/madgraph/interface/master_interface.py", line 44, in <module>
    import madgraph.interface.madgraph_interface as MGcmd
  File "/mnt/c/Users/Jack/OneDrive/Documents/MG5_aMC_v3_3_1/madgraph/interface/madgraph_interface.py", line 88, in <module>
    import madgraph.loop.loop_exporters as loop_exporters
  File "/mnt/c/Users/Jack/OneDrive/Documents/MG5_aMC_v3_3_1/madgraph/loop/loop_exporters.py", line 232, in <module>
    class LoopProcessExporterFortranSA(LoopExporterFortran,
  File "/mnt/c/Users/Jack/OneDrive/Documents/MG5_aMC_v3_3_1/madgraph/loop/loop_exporters.py", line 241, in LoopProcessExporterFortranSA
    MadLoop_banner = MadLoopBannerStyles.get_MadLoop_Banner(
  File "/mnt/c/Users/Jack/OneDrive/Documents/MG5_aMC_v3_3_1/madgraph/loop/MadLoopBannerStyles.py", line 254, in get_MadLoop_Banner
    version = "v%(version)s (%(date)s)"%misc.get_pkg_info()
KeyError: 'version'

Tried turning it off and on, tried redownloading the current release and the 2.9 release, checked my VERSION file is there (it says version = 3.3.1
date = 2021-12-04).

Still doesn't work. Any ideas?

Revision history for this message
Jack (effrit) wrote :

Fixed it, there was an empty VERSION file in all of my madgraph folders, which was being used. I replaced it with another copy of the actual one, and it seems to work now

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments