issue with 4 body decay and identical particles

Bug #1902788 reported by Olivier Mattelaer
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
Undecided
Unassigned

Bug Description

Hi,

MG5_aMC is crashing when automatically calculation widths using the Pseudoscalar_2HDM model (*):

Command "generate_events run_01" interrupted in sub-command:
"set max_npoint_for_channel 0" with error:
KeyError : 2

Versions 2.8.1 and 2.8.2 seem to be affected, the same thing used to work in 2.6.7.
We are using python2.

We are essentially calling:
> import model Pseudoscalar_2HDM-bbMET_5FS --modelname
> generate p p > t t~ #doesn't really matter
> output test
> launch
> done
> set Wh1 auto
> set Wh2 auto
> set Wh3 auto
> set Wh4 auto
> done

I've copied the MG5_debug at the bottom of this message (there is also a ME5_debug file which is empty).

Any help with this would be appreciated.

Cheers,
Hannes

*) https://github.com/LHC-DMWG/model-repository/tree/master/models/Pseudoscalar_2HDM

---MG5_debug.log---

#************************************************************
#* MadGraph5_aMC@NLO *
#* *
#* * * *
#* * * * * *
#* * * * * 5 * * * * *
#* * * * * *
#* * * *
#* *
#* *
#* VERSION 2.8.2 2020-10-30 *
#* *
#* The MadGraph5_aMC@NLO Development Team - Find us at *
#* https://server06.fynu.ucl.ac.be/projects/madgraph *
#* *
#************************************************************
#* *
#* Command File for MadGraph5_aMC@NLO *
#* *
#* run as ./bin/mg5_aMC filename *
#* *
#************************************************************
set group_subprocesses Auto
set ignore_six_quark_processes False
set max_t_for_channel 99
set loop_optimized_output True
set low_mem_multicore_nlo_generation False
set default_unset_couplings 99
set zerowidth_tchannel True
set loop_color_flows False
set gauge unitary
set complex_mass_scheme False
set max_npoint_for_channel 0
Traceback (most recent call last):
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1541, in onecmd
    return self.onecmd_orig(line, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1490, in onecmd_orig
    return func(arg, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/madevent_interface.py", line 2463, in do_generate_events
    switch_mode = self.ask_run_configuration(mode, args)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/madevent_interface.py", line 6234, in ask_run_configuration
    self.ask_edit_cards(cards, plot=False, first_cmd=first_cmd)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/common_run_interface.py", line 982, in ask_edit_cards
    banner=banner)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/common_run_interface.py", line 1054, in ask_edit_card_static
    cards=cards, mode=mode, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1150, in ask
    fct=question_instance, fct_timeout=fct_timeout)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1755, in timed_input
    result = fct(question)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 2118, in __call__
    return self.cmdloop()
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 2286, in cmdloop
    super(SmartQuestion,self).cmdloop(intro)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 179, in cmdloop
    stop = self.postcmd(stop, line)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/common_run_interface.py", line 6081, in postcmd
    self.do_update('dependent', timer=20)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/common_run_interface.py", line 6127, in do_update
    self.do_compute_widths('')
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/common_run_interface.py", line 6498, in do_compute_widths
    out = self.mother_interface.do_compute_widths(line)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/common_run_interface.py", line 2318, in do_compute_widths
    out = cmd.exec_cmd(line, model=opts['model'])
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1570, in exec_cmd
    stop = Cmd.onecmd_orig(current_interface, line, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1490, in onecmd_orig
    return func(arg, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/master_interface.py", line 346, in do_compute_widths
    return self.cmd.do_compute_widths(self, *args, **opts)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/madgraph_interface.py", line 8500, in do_compute_widths
    self.exec_cmd('output madevent %s -f' % decay_dir,child=False)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1570, in exec_cmd
    stop = Cmd.onecmd_orig(current_interface, line, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/extended_cmd.py", line 1490, in onecmd_orig
    return func(arg, **opt)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/master_interface.py", line 299, in do_output
    self.cmd.do_output(self, line, *args, **opts)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/madgraph_interface.py", line 7993, in do_output
    self.export(nojpeg, main_file_name, group_processes, args)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/master_interface.py", line 313, in export
    return self.cmd.export(self, *args, **opts)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/madgraph_interface.py", line 8123, in export
    ndiags, cpu_time = generate_matrix_elements(self,group_processes)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/interface/madgraph_interface.py", line 8105, in generate_matrix_elements
    matrix_element_opts=mode)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/core/helas_objects.py", line 5588, in __init__
    compute_loop_nc = compute_loop_nc))
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/core/helas_objects.py", line 5815, in generate_matrix_elements
    amplitude_tag = IdentifyMETag.create_tag(amplitude)
  File "/home/hmildner/HEP/MG5_aMC_v2_8_2/madgraph/core/helas_objects.py", line 117, in create_tag
    for p in sorted_tags[1:]]
KeyError: 2
                          MadGraph5_aMC@NLO Options
                          ----------------
        complex_mass_scheme : False
    default_unset_couplings : 99 (user set)
                      gauge : unitary
         group_subprocesses : Auto
  ignore_six_quark_processes : False
           loop_color_flows : False
      loop_optimized_output : True
  low_mem_multicore_nlo_generation : False
     max_npoint_for_channel : 0 (user set)
          max_t_for_channel : 99 (user set)
               stdout_level : 20 (user set)
         zerowidth_tchannel : True

                         MadEvent Options
                          ----------------
     automatic_html_opening : False (user set)
                    nb_core : 4 (user set)
        notification_center : True
                   run_mode : 2

                      Configuration Options
                      ---------------------
                        OLP : MadLoop
                    amcfast : amcfast-config
                   applgrid : applgrid-config
                auto_update : 7 (user set)
         cluster_local_path : None
           cluster_nb_retry : 1
              cluster_queue : None (user set)
         cluster_retry_wait : 300
               cluster_size : 100
      cluster_status_update : (600, 30)
          cluster_temp_path : None
               cluster_type : condor
                    collier : ./HEPTools/lib
               cpp_compiler : None
             crash_on_error : False
               delphes_path : None (user set)
                 eps_viewer : None
        exrootanalysis_path : None (user set)
              f2py_compiler : None
          f2py_compiler_py2 : None
          f2py_compiler_py3 : None
                    fastjet : fastjet-config
           fortran_compiler : None
                      golem : None (user set)
                 hepmc_path : None (user set)
                  hwpp_path : None (user set)
                     lhapdf : lhapdf-config
                 lhapdf_py2 : None
                 lhapdf_py3 : None
          madanalysis5_path : None (user set)
           madanalysis_path : None (user set)
  mg5amc_py8_interface_path : None (user set)
                      ninja : ./HEPTools/lib
        output_dependencies : external
            pythia-pgs_path : None (user set)
               pythia8_path : None (user set)
                    samurai : None
               syscalc_path : None (user set)
                    td_path : None (user set)
                text_editor : emacs (user set)
                thepeg_path : None (user set)
                    timeout : 60
                web_browser : None

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) wrote :

Hi,

This is clearly related to a bug that we have fixed in 2.8.1 (the bug fixing was related to identical in the final state where some diagram were not included). Looks like for your process some 4 body diagram added due to that issue have some issue with the meta-data leading to this crash.

This is likely to be quite long to fix (and I would not recommend to use older version in your case).

Cheers,

Olivier

Changed in mg5amcnlo:
status: New → Confirmed
Revision history for this message
Hannes (hannes3) wrote :

Hi Olivier,

thanks!
Just to make sure I get it right because there is a large set of samples depending on this: this is buggy versions older than 2.8.1 and crashes from 2.8.1 onwards, meaning we cannot use the auto width calculation for this model? Is there a workaround you can recommend?

Cheers,
Hannes

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) wrote : Re: [Bug 1902788] issue with 4 body decay and identical particles
Download full text (11.0 KiB)

Hi,

I would suggest to compute the width in a different way (analytically if possible).
and compare the result with the 2.8.0 (or earlier version) this will tell you how big that bug is in your case.

Cheers,

Olivier

> On 3 Nov 2020, at 21:59, Hannes <email address hidden> wrote:
>
> Hi Olivier,
>
> thanks!
> Just to make sure I get it right because there is a large set of samples depending on this: this is buggy versions older than 2.8.1 and crashes from 2.8.1 onwards, meaning we cannot use the auto width calculation for this model? Is there a workaround you can recommend?
>
> Cheers,
> Hannes
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1902788
>
> Title:
> issue with 4 body decay and identical particles
>
> Status in MadGraph5_aMC@NLO:
> Confirmed
>
> Bug description:
> Hi,
>
> MG5_aMC is crashing when automatically calculation widths using the
> Pseudoscalar_2HDM model (*):
>
> Command "generate_events run_01" interrupted in sub-command:
> "set max_npoint_for_channel 0" with error:
> KeyError : 2
>
> Versions 2.8.1 and 2.8.2 seem to be affected, the same thing used to work in 2.6.7.
> We are using python2.
>
> We are essentially calling:
>> import model Pseudoscalar_2HDM-bbMET_5FS --modelname
>> generate p p > t t~ #doesn't really matter
>> output test
>> launch
>> done
>> set Wh1 auto
>> set Wh2 auto
>> set Wh3 auto
>> set Wh4 auto
>> done
>
> I've copied the MG5_debug at the bottom of this message (there is also
> a ME5_debug file which is empty).
>
> Any help with this would be appreciated.
>
> Cheers,
> Hannes
>
> *) https://github.com/LHC-DMWG/model-
> repository/tree/master/models/Pseudoscalar_2HDM
>
> ---MG5_debug.log---
>
> #************************************************************
> #* MadGraph5_aMC@NLO *
> #* *
> #* * * *
> #* * * * * *
> #* * * * * 5 * * * * *
> #* * * * * *
> #* * * *
> #* *
> #* *
> #* VERSION 2.8.2 2020-10-30 *
> #* *
> #* The MadGraph5_aMC@NLO Development Team - Find us at *
> #* https://server06.fynu.ucl.ac.be/projects/madgraph *
> #* *
> #************************************************************
> #* *
> #* Command File for MadGraph5_aMC@NLO *
> #* *
> #* run as ./bin/mg5_aMC filename *
> #* *
> #******************************************...

Revision history for this message
Hannes (hannes3) wrote :

Hi Olivier,

thanks. Final question: what is the extend of the bug in the older releases? Which processes, models, or use cases would be affected by it?

Cheers,
Hannes

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) wrote :
Download full text (11.0 KiB)

So this a bug affecting only the computation of the auto-width.
This affects computation of width for
1>3 and 1>4 with identical particles in the final state.

So for the model/processes affected this obviously only impact processes where
1>2 body decay are not the main bluk of the width (which should be most of the model obviously)

Cheers,

Olivier

> On 3 Nov 2020, at 22:29, Hannes <email address hidden> wrote:
>
> Hi Olivier,
>
> thanks. Final question: what is the extend of the bug in the older
> releases? Which processes, models, or use cases would be affected by it?
>
> Cheers,
> Hannes
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1902788
>
> Title:
> issue with 4 body decay and identical particles
>
> Status in MadGraph5_aMC@NLO:
> Confirmed
>
> Bug description:
> Hi,
>
> MG5_aMC is crashing when automatically calculation widths using the
> Pseudoscalar_2HDM model (*):
>
> Command "generate_events run_01" interrupted in sub-command:
> "set max_npoint_for_channel 0" with error:
> KeyError : 2
>
> Versions 2.8.1 and 2.8.2 seem to be affected, the same thing used to work in 2.6.7.
> We are using python2.
>
> We are essentially calling:
>> import model Pseudoscalar_2HDM-bbMET_5FS --modelname
>> generate p p > t t~ #doesn't really matter
>> output test
>> launch
>> done
>> set Wh1 auto
>> set Wh2 auto
>> set Wh3 auto
>> set Wh4 auto
>> done
>
> I've copied the MG5_debug at the bottom of this message (there is also
> a ME5_debug file which is empty).
>
> Any help with this would be appreciated.
>
> Cheers,
> Hannes
>
> *) https://github.com/LHC-DMWG/model-
> repository/tree/master/models/Pseudoscalar_2HDM
>
> ---MG5_debug.log---
>
> #************************************************************
> #* MadGraph5_aMC@NLO *
> #* *
> #* * * *
> #* * * * * *
> #* * * * * 5 * * * * *
> #* * * * * *
> #* * * *
> #* *
> #* *
> #* VERSION 2.8.2 2020-10-30 *
> #* *
> #* The MadGraph5_aMC@NLO Development Team - Find us at *
> #* https://server06.fynu.ucl.ac.be/projects/madgraph *
> #* *
> #************************************************************
> #* *
> #* Command File for MadGraph5_aMC@NLO *
> #* *
> #* run as ./bin/mg5_aMC filename *
> #* *
> #*******************************************...

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) wrote :

this patch/version is fixing the issue:
https://bazaar.launchpad.net/~maddevelopers/mg5amcnlo/LTS_dev/revision/327

Thanks,

Olivier

Changed in mg5amcnlo:
status: Confirmed → Fix Committed
Changed in mg5amcnlo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers