second_refine_treshold error after event generation

Bug #1884578 reported by Olivier Dupon on 2020-06-22

This bug report will be marked for expiration in 24 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
Undecided
Unassigned

Bug Description

Dear MadGraph Team,

I encountered an error that I don't know how to resolve when I try to generate events from an imported model. This error only occured after I updated my MadGraph today.

When I try to generate said events I get the following error:

************************************************************
* *
* W E L C O M E to *
* M A D G R A P H 5 _ a M C @ N L O *
* *
* *
* * * *
* * * * * *
* * * * * 5 * * * * *
* * * * * *
* * * *
* *
* VERSION 2.7.0 2020-01-20 *
* *
* The MadGraph5_aMC@NLO Development Team - Find us at *
* https://server06.fynu.ucl.ac.be/projects/madgraph *
* and *
* http://amcatnlo.web.cern.ch/amcatnlo/ *
* *
* Type 'help' for in-line help. *
* Type 'tutorial' to learn how MG5 works *
* Type 'tutorial aMCatNLO' to learn how aMC@NLO works *
* Type 'tutorial MadLoop' to learn how MadLoop works *
* *
************************************************************
load MG5 configuration from input/mg5_configuration.txt
Using golem library in /cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-slc6-gcc62-dbg/lib
set fastjet to fastjet-config
set lhapdf to lhapdf-config
Using default text editor "vi". Set another one in ./input/mg5_configuration.txt
No valid web browser found. Please set in ./input/mg5_configuration.txt
set automatic_html_opening False --no_save
compute_widths 34 --precision_channel=0.01 --body_decay=4.0025 --path=/storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/PROC_WEff_UFO_4/Cards/param_card.dat --output=/storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/PROC_WEff_UFO_4/Cards/param_card.dat
Please note that the automatic computation of the width is
    only valid in narrow-width approximation and at tree-level.
INFO: Get two body decay from FeynRules formula
Results written to /storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/PROC_WEff_UFO_4/Cards/param_card.dat
INFO: get decay diagram for wp+
Vertexlist of this model has not been searched.Automatically run the model.find_vertexlist()
Found 3 stable particles
No decay is found
No need for N body-decay (N>2). Results are in /storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/PROC_WEff_UFO_4/Cards/param_card.dat
INFO: Update the dependent parameter of the param_card.dat
WARNING: Failed to update dependent parameter. This might create trouble for external program (like MadSpin/shower/...)
Generating 10000 events with run name run_01
survey run_01
INFO: compile directory
compile Source Directory
Using random number seed offset = 21
INFO: Running Survey
Creating Jobs
Working on SubProcesses
INFO: P1_emep_bbxepemvlvl
INFO: Idle: 26, Running: 8, Completed: 0 [ current time: 18h51 ]
INFO: Idle: 25, Running: 8, Completed: 1 [ 0.59s ]
INFO: Idle: 21, Running: 8, Completed: 5 [ 4.6s ]
INFO: Idle: 17, Running: 8, Completed: 9 [ 8.5s ]
INFO: Idle: 13, Running: 8, Completed: 13 [ 13s ]
INFO: Idle: 10, Running: 8, Completed: 16 [ 16.2s ]
INFO: Idle: 7, Running: 8, Completed: 19 [ 21.3s ]
INFO: Idle: 5, Running: 8, Completed: 21 [ 29.2s ]
INFO: Idle: 2, Running: 8, Completed: 24 [ 33.9s ]
INFO: Idle: 1, Running: 8, Completed: 25 [ 37.2s ]
INFO: Idle: 0, Running: 6, Completed: 28 [ 41.4s ]
INFO: Idle: 0, Running: 4, Completed: 30 [ 47.1s ]
INFO: Idle: 0, Running: 3, Completed: 31 [ 1m 4s ]
INFO: Idle: 0, Running: 1, Completed: 33 [ 1m 15s ]
INFO: Idle: 0, Running: 0, Completed: 34 [ 1m 24s ]
INFO: Idle: 0, Running: 0, Completed: 34 [ 1m 24s ]
INFO: End survey
refine 10000
Creating Jobs
INFO: Refine results to 10000
INFO: Generating 10000.0 unweighted events.
INFO: Effective Luminosity 2493105.64962 pb^-1
INFO: need to improve 3 channels
- Current estimate of cross-section: 0.00481327375831 +- 6.9755703137e-05
    P1_emep_bbxepemvlvl
INFO: Idle: 6, Running: 8, Completed: 0 [ current time: 18h52 ]
INFO: Idle: 5, Running: 8, Completed: 1 [ 0.88s ]
INFO: Idle: 0, Running: 2, Completed: 12 [ 5.6s ]
INFO: Idle: 0, Running: 0, Completed: 14 [ 22.7s ]
INFO: Idle: 0, Running: 0, Completed: 14 [ 22.8s ]
INFO: Combining runs
INFO: finish refine
Command "generate_events run_01" interrupted with error:
KeyError : 'second_refine_treshold'
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in '/storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/PROC_WEff_UFO_4/run_01_tag_1_debug.log'.
Please attach this file to your report.
INFO:
quit
INFO:
MG5_aMC>

Hi,

Thanks a lot for the feedback and sorry for the trouble.

Could you attach the files:
1. /storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/PROC_WEff_UFO_4/run_01_tag_1_debug.log
2. /storage_mnt/storage/user/odupon/MG5_aMC_v2_7_0/madgraph/various/banner.py

Maybe one work-around to this bug would be to add the line
0.9 = second_refine_treshold
in the run_card but my guess is that this is just going to create a crash at the compilation time (if like I think, your file madgraph/various/banner.py was not updated correctly.)

You can see here the changes that should have been done to that file:
https://bazaar.launchpad.net/~madteam/mg5amcnlo/series2.0/revision/288#madgraph/various/banner.py

I have checked the uiuc and the ucl server and the command requesting the change to that file are correct. I have also run the update function from 2.7.2 to 2.7.3 and I do not reproduce that error.

Maybe one solution independently of the above question is to install a clean version from this link: https://launchpad.net/mg5amcnlo/2.0/2.7.x/+download/MG5_aMC_v2.7.3.tar.gz

Thanks,

Olivier

Olivier Dupon (odupon) wrote :

Hi Olivier

Here is my banner.py and I'll attach the log in the next comment. I have noticed that besides the banner.py I also have a banner.py.orig and a banner.py.rej maybe that could be part of the cause.

Kind regards
Olivier Dupon

Olivier Dupon (odupon) wrote :

Here is the log.

Here is my banner.py and I'll attach the log in the next comment. I have noticed that besides the banner.py I also have a banner.py.orig and a banner.py.rej maybe that could be part of the cause.

Yes this means that the patches fails for some reason. Did you ever open that file?
The cleanest is likely to re-install a clean version from the official tarball then.

Thanks,

Olivier

Changed in mg5amcnlo:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions