Bug for VBS-like processes, with the low_mem_multicore_generation

Bug #1843676 reported by marco zaro
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
Undecided
marco zaro

Bug Description

Dear Authors,

I would like to generate the NLO QCD correction to the process of WWjj->lvlvjj.

 What I did was:

generate p p > e+ ve mu- vm~ j j [QCD]
add process p p > mu+ vm e- ve~ j j [QCD]

Generating the FKS-subtracted matrix element for Born process is relatively quick, ±30mins, but it takes a few hours to generate the virtual matrix-elements using Madloop and this step worked fine and was complete. After this was complete I then ran,

output ppWWjj

The problem occurs when I try to create the corresponding output for MadGraph5_aMC@NLO.

The generation of matrix-elements in "output" ends at 88/240. Since it stops I have no log file to look at and resolve this issue. Also, there is no error.

I tried running the process on different machines with my colleagues and still, the output suddenly stops.

Note: I am using:
 macOS Mojave Version 10.14
, MG5_aMC_v2_6_5,
GNU Fortran (GCC) 6.2.0
, Python 2.7.15

Any advice into the solution for this would be greatly appreciated.

Kind regards,

Lebohang.

Revision history for this message
marco zaro (marco-zaro) wrote :

Dear Lebohang,
first of all, apologies for the long silence on this.
We had time to investigate your issue, and it turned out that there is a bug related to the process combination when the low_mem_multicore_nlo_generation mode is used.
I attach a patch that should solve that issue, it would be great if you could confirm that it does.
We are still studying the problem, and we will decide soon whether to apply the patch to the main release of MG5_aMC

Thanks again,

Best wishes,

Marco

Changed in mg5amcnlo:
assignee: nobody → marco zaro (marco-zaro)
Revision history for this message
Olivier Mattelaer (olivier-mattelaer) wrote :

Hi Marco,

any update on this?

Olivier

PS: Note that low_mem_multicore_nlo_generation will not be supported anymore when we will move to python3 (but if someone spend the needed time to fix the issue of that function obviously)

Revision history for this message
marco zaro (marco-zaro) wrote : Re: [Bug 1843676] Re: Bug for VBS-like processes, with the low_mem_multicore_generation

Hi Olivier,
I attached a patch to the bug report long ago, but i am not sure to commit it in the main branches. Nonetheless, since the fix is there and it is available, I have marked as ‘fix committed’.

Let me know if this is ok with you.

Then, what is the problem with python 3? is it due to the pool/multiprocessing module?

Thanks!

Cheers,

Marco

> On 16 Oct 2019, at 20:54, Olivier Mattelaer <email address hidden> wrote:
>
> Hi Marco,
>
> any update on this?
>
> Olivier
>
> PS: Note that low_mem_multicore_nlo_generation will not be supported
> anymore when we will move to python3 (but if someone spend the needed
> time to fix the issue of that function obviously)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1843676
>
> Title:
> Bug for VBS-like processes, with the low_mem_multicore_generation
>
> Status in MadGraph5_aMC@NLO:
> New
>
> Bug description:
> Dear Authors,
>
> I would like to generate the NLO QCD correction to the process of
> WWjj->lvlvjj.
>
> What I did was:
>
> generate p p > e+ ve mu- vm~ j j [QCD]
> add process p p > mu+ vm e- ve~ j j [QCD]
>
>
>
> Generating the FKS-subtracted matrix element for Born process is
> relatively quick, ±30mins, but it takes a few hours to generate the
> virtual matrix-elements using Madloop and this step worked fine and
> was complete. After this was complete I then ran,
>
> output ppWWjj
>
>
>
> The problem occurs when I try to create the corresponding output for
> MadGraph5_aMC@NLO.
>
> The generation of matrix-elements in "output" ends at 88/240. Since it
> stops I have no log file to look at and resolve this issue. Also,
> there is no error.
>
> I tried running the process on different machines with my colleagues
> and still, the output suddenly stops.
>
> Note: I am using:
> macOS Mojave Version 10.14
> , MG5_aMC_v2_6_5,
> GNU
> Fortran (GCC) 6.2.0
> , Python 2.7.15
>
>
>
> Any advice into the solution for this would be greatly appreciated.
>
> Kind regards,
>
> Lebohang.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mg5amcnlo/+bug/1843676/+subscriptions

Changed in mg5amcnlo:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions