KeyError failure on "output" command

Bug #1800236 reported by Luca on 2018-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
Undecided
Unassigned

Bug Description

Dear experts,

I am trying to generate gg > HH events in MadGraph5_aMC@NLO.
I have a workflow that worked properly in a previous code version (v2.6.1).
However, as I switched to the latest release (v2.6.3.2), I get the error [1] upon calling the "output" command.
I am attaching the debug file if that can be useful.
A minimal set of instruction to reproduce the problem is in [2].

Although the model is not the most recent one, it would be good to have the capability to run it to test against newer implementations, but unfortunately v2.6.1 is not available anymore for download from your website.

Since I had in the downloads folder on my machine v2.6.1, I could check on a "fresh install" that the instructions [2] work in v2.6.1 but fail in v2.6.3.2 .
I can of course continue to work in the older version, but I hope that this report may be useful anyway, or that a simple solution to work in the latest release exists.

Best,
Luca

[1]
Command "output test" interrupted with error:
KeyError : (0,)
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in 'MG5_debug'.
Please attach this file to your report.

[2]
cd models
wget https://cms-project-generators.web.cern.ch/cms-project-generators/BSM_gg_hh.tar
tar -xvf BSM_gg_hh.tar
./bin/mg5_aMC

And inside the session:
import BSM_gg_hh
generate g g > h h
output test_folder
exit

Luca (cadaluca90) wrote :
Download full text (3.8 KiB)

Hi,

I believe that this bug is already fixed in our development version.
The problem is that your model was not following the UFO convention and therefore was not compatible with the latest optimization that we applied in the handling of the UFO model. I have de-activated such optimisation for fake UFO model.

Cheers,

Olivier

> On 26 Oct 2018, at 23:49, Luca <email address hidden> wrote:
>
> Public bug reported:
>
> Dear experts,
>
> I am trying to generate gg > HH events in MadGraph5_aMC@NLO.
> I have a workflow that worked properly in a previous code version (v2.6.1).
> However, as I switched to the latest release (v2.6.3.2), I get the error [1] upon calling the "output" command.
> I am attaching the debug file if that can be useful.
> A minimal set of instruction to reproduce the problem is in [2].
>
> Although the model is not the most recent one, it would be good to have
> the capability to run it to test against newer implementations, but
> unfortunately v2.6.1 is not available anymore for download from your
> website.
>
> Since I had in the downloads folder on my machine v2.6.1, I could check on a "fresh install" that the instructions [2] work in v2.6.1 but fail in v2.6.3.2 .
> I can of course continue to work in the older version, but I hope that this report may be useful anyway, or that a simple solution to work in the latest release exists.
>
> Best,
> Luca
>
> [1]
> Command "output test" interrupted with error:
> KeyError : (0,)
> Please report this bug on https://bugs.launchpad.net/mg5amcnlo
> More information is found in 'MG5_debug'.
> Please attach this file to your report.
>
> [2]
> cd models
> wget https://cms-project-generators.web.cern.ch/cms-project-generators/BSM_gg_hh.tar
> tar -xvf BSM_gg_hh.tar
> ./bin/mg5_aMC
>
> And inside the session:
> import BSM_gg_hh
> generate g g > h h
> output test_folder
> exit
>
> ** Affects: mg5amcnlo
> Importance: Undecided
> Status: New
>
> ** Attachment added: "debug file"
> https://bugs.launchpad.net/bugs/1800236/+attachment/5206065/+files/MG5_debug
>
> --
> You received this bug notification because you are subscribed to
> MadGraph5_aMC@NLO.
> https://bugs.launchpad.net/bugs/1800236
>
> Title:
> KeyError failure on "output" command
>
> Status in MadGraph5_aMC@NLO:
> New
>
> Bug description:
> Dear experts,
>
> I am trying to generate gg > HH events in MadGraph5_aMC@NLO.
> I have a workflow that worked properly in a previous code version (v2.6.1).
> However, as I switched to the latest release (v2.6.3.2), I get the error [1] upon calling the "output" command.
> I am attaching the debug file if that can be useful.
> A minimal set of instruction to reproduce the problem is in [2].
>
> Although the model is not the most recent one, it would be good to
> have the capability to run it to test against newer implementations,
> but unfortunately v2.6.1 is not available anymore for download from
> your website.
>
> Since I had in the downloads folder on my machine v2.6.1, I could check on a "fresh install" that the instructions [2] work in v2.6.1 but fail in v2.6.3.2 .
> I can of course continue to work in the older version, but I hope that this re...

Read more...

Luca (cadaluca90) wrote :

Hi Olivier,
that's great to hear, I will wait for the next release implementing this fix then.
Best,
Luca

Changed in mg5amcnlo:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments