"list index out of range" in calculate decay width

Bug #1246957 reported by teddym on 2013-11-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
Undecided
Unassigned

Bug Description

I want to calculate some process in model mssm-full using my own parameter cards with a final state h1 decays into two w-boson and further into three cases: dilepton, semi-lepton and full-hardronic. However the cross sections for these three situations are not in my expecting.

Dilepton : 0.0436 pb
semilep: 0.1225 pb
fullhard: 0.04594 pb

In my view, althouth there would be at least one off-shell w-boson, the ratio among these three cases would be:

dilep: semi: hard ~ 1:4:4

So I want to check the decay of higgs h1 into w- w+ in these three mode in mssm using my own parameter card, and I get this report
"
Command "calculate_decay_widths run_01" interrupted with error:
IndexError : list index out of range
Please report this bug on https://bugs.launchpad.net/madgraph5
More information is found in '/home/zyan12/workingspace/MadGraph5_v1_5_12/TEDWORK/HIGGSDECAY/MSSM/Dilep/run_01_tag_1_debug.log'.
Please attach this file to your report.

"

The following is the log file:

calculate_decay_widths run_01
Traceback (most recent call last):
  File "/home/zyan12/workingspace/MadGraph5_v1_5_12/madgraph/interface/extended_cmd.py", line 819, in onecmd
    return self.onecmd_orig(line, **opt)
  File "/home/zyan12/workingspace/MadGraph5_v1_5_12/madgraph/interface/extended_cmd.py", line 812, in onecmd_orig
    return func(arg, **opt)
  File "/home/zyan12/workingspace/MadGraph5_v1_5_12/madgraph/interface/madevent_interface.py", line 2382, in do_calculate_decay_widths
    self.collect_decay_widths()
  File "/home/zyan12/workingspace/MadGraph5_v1_5_12/madgraph/interface/madevent_interface.py", line 2413, in collect_decay_widths
    output=pjoin(self.me_dir, 'Events', run_name, "param_card.dat"))
  File "/home/zyan12/workingspace/MadGraph5_v1_5_12/madgraph/interface/madevent_interface.py", line 2463, in update_width_in_param_card
    line=param_card[line_number]
IndexError: list index out of range
                              Run Options
                              -----------
               stdout_level : 20 (user set)

                         MadEvent Options
                         ----------------
     automatic_html_opening : False (user set)
          cluster_temp_path : None
              cluster_queue : None (user set)
                    nb_core : 4 (user set)
                   run_mode : 2

                      Configuration Options
                      ---------------------
                web_browser : None
                text_editor : None
           madanalysis_path : /home/zyan12/workingspace/MadGraph5_v1_5_12/MadAnalysis (user set)
               pythia8_path : None (user set)
            pythia-pgs_path : /home/zyan12/workingspace/MadGraph5_v1_5_12/pythia-pgs (user set)
                    td_path : /home/zyan12/workingspace/MadGraph5_v1_5_12/td (user set)
               delphes_path : /home/zyan12/workingspace/MadGraph5_v1_5_12/Delphes (user set)
                auto_update : 7 (user set)
               cluster_type : condor
           fortran_compiler : None (user set)
        exrootanalysis_path : /home/zyan12/workingspace/MadGraph5_v1_5_12/ExRootAnalysis (user set)
                 eps_viewer : None
                    timeout : 60

Related branches

teddym (niepanchongsheng) wrote :

Hi Teddym,

Could you attach your param_card?
This seems to be linked to a syntax that I'm not parsing correctly (and/or an invalid syntax in your file)

Cheers,

Olivier

Changed in madgraph5:
status: New → Incomplete
Changed in madgraph5:
status: Incomplete → Won't Fix
teddym (niepanchongsheng) wrote :

Hi
     I'm sorry I didn't notice the response before. I attach the parameter card I used. This problem happens many times when I calculate decay width.

Ted
2013-12-8

Thanks Teddym,

I will look at this.

Cheers,

Olivier

Changed in madgraph5:
status: Won't Fix → In Progress

Hi Ted,

Thanks a lot for your param_card,
the problem is linked that that you don't have an empty line at the end of your file.
This will not be a problem in the next release, but in the mean time, the easiest is to add an empty line at the end of your files.

Thanks a lot for this report,

Olivier

Changed in madgraph5:
status: In Progress → Fix Committed
teddym (niepanchongsheng) wrote :

Hi Olivier

    No more problems after adding an empty line. Thanks very much!

Ted

Changed in madgraph5:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions