The Metacity Window Manager

Metacity needs command line options to activate capture before unmap and compositing without effects

Reported by Florian Boucault on 2011-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
metacity
Fix Committed
Undecided
Unassigned
unity-2d
High
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

In order to allow a smooth fallback from Unity 3D to 2D within the same session when lack of hardware/drivers support requires it, Metacity needs to be launched with the right options:
- capture before unmap activated
- compositing activated
- advanced compositing effects deactivated

This configuration of metacity should not be persistent and discarded as soon as the session exits (as to not impact for example the GNOME 2 session). Because of that it cannot be done through GConf/DConf and we should implement them as command line switches.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Didier Roche (didrocks) on 2011-06-06
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Florian Boucault (fboucault) wrote :

Update:

The scope is in fact bigger than previously thought: 2 other options were forgotten that need to be set only in a Unity 2D session:

/apps/metacity/general/show_maximized_titlebars false
/apps/metacity/general/auto_maximize_windows true

A new simpler, more generic solution was thought by Didier: adding a command line option to metacity where one could pass a file containing a set of GConf key/value pairs that override the current ones.

Changed in unity-2d:
milestone: none → 3.8.10
Didier Roche (didrocks) on 2011-07-04
Changed in unity-2d:
milestone: 3.8.10 → 3.8.12
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
milestone: 3.8.12 → 3.8.14
Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-08-11
Changed in unity-2d:
milestone: 4.0 → 4.2
Alberto Mardegan (mardy) on 2011-08-24
Changed in metacity:
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :
Changed in metacity:
status: New → In Progress
Changed in unity-2d:
milestone: 4.2 → 4.4
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Changed in metacity:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.6.1-0ubuntu1

---------------
unity-2d (4.6.1-0ubuntu1) oneiric; urgency=low

  * Fix a segfault due to new unity service backend change.

unity-2d (4.6.0-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Metacity needs command line options to activate capture before unmap and
      compositing without effects (LP: #791205)
    - Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
      in the panel (LP: #808849)
    - the migration script needs to be run in unity-2d as well (LP: #819733)
    - [dash] "View photos" in the dash launches default image viewer instead
      of shotwell (LP: #822605)
    - Launcher tooltips sometimes leave holes in panel and windows
      (LP: #837277)
    - [dash] Search with non ascii characters fails (LP: #840010)
    - add a configuration key (dconf) to enable the opengl backend
      (LP: #809202)
    - [launcher] when pressing super key shortcuts numbering start at 2
      instead of 1 (LP: #830036)
    - [UIFe] Unity 2D should be using the same BFB icon as Unity (LP: #838829)
    - [launcher] trash icon needs to be the same as in Unity 3D (LP: #840025)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - [dash] DropShadow on "See X more results" can cause visual errors on
      scroll (LP: #843820)
    - Dash - In the App lens filters, users should only be able filter by
      'star' rating in one star increments (LP: #839759)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
  * debian/control:
    - rebuild against current nux and unity (API change)
 -- Didier Roche <email address hidden> Fri, 09 Sep 2011 13:50:22 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) on 2012-08-30
Changed in metacity:
assignee: Alberto Mardegan (mardy) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.