desktop switching issue

Bug #54410 reported by gwilson on 2006-07-29
6
Affects Status Importance Assigned to Milestone
Metacity
Confirmed
Wishlist
metacity (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

I have the following keys bound to switching virtual desktops:

ctrl+alt+right = move one desktop to the "right"
ctrl+alt+left = move to the left

To reproduce the bug:
1) hold ctrl+alt
2) press left (or right)
3) release ctrl, but continue holding alt
4) press left or right -- desktop switches (unexpected)

I don't know if this is an Ubuntu problem, or gnome, or something specific to my installation. Also, don't consider it a big deal. But I DO think it makes the gui seem un-polished, and expect it can be easily fixed.

Cheers.

Dennis Kaarsemaker (dennis) wrote :

I see that too, punting to a gnome package so seb sees the bug

Sebastien Bacher (seb128) wrote :

That behaviour is probably a window manager one. Why do you consider that as a bug? Just unpress ctrl and alt if you want to stop it

Changed in gnome-session:
status: Confirmed → Needs Info
gwilson (gwilson) wrote :

sb, don't really know how to answer that... I can't imagine this is the intended behaviour, so I consider it a bug.
-- Greg.

Sebastien Bacher (seb128) wrote :

what is wrong with the behaviour? you press a combinaison of modifiers and a key and the feature is activated until you unpress the modifiers, that's wrong to you?

gwilson (gwilson) wrote :

my expectation was that the desktop would switch only if ctrl+alt+direction were pressed all at the same time, and never otherwise. That's the way things work in most other programs; for example, if you hold ctl+shift+left in a text editor (with PC-like bindings) it highlights one word to the left. Then continue holding shift and press left (or right) and it will highlight a char at a time.

Sebastien Bacher (seb128) wrote :

that's not like you had no notification, the desktop switcher is still display in the middle of the screen

setting as a wishlist if somebody wants to forward it upstream feel free, we have lot of bug to work on at the moment and that's one is not a priority to fix for the desktop team

Changed in metacity:
importance: Untriaged → Wishlist
status: Needs Info → Confirmed
Changed in metacity:
status: New → Unknown
Changed in metacity:
status: Unknown → Confirmed
Changed in metacity (Ubuntu):
status: Confirmed → Triaged
Changed in metacity:
importance: Unknown → Wishlist

Is this still a bug in Ubuntu 10.04 LTS?

Chris Carlin (crcarlin) wrote :

I tried to reproduce the bug, and it doesn't seem to happen now, so I'm closing the bug as fixed.

Changed in metacity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.