"Compose New Message" and "Contacts" are untranslated when Thunderbird is running

Bug #917920 reported by Pavol Klačanský on 2012-01-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Messaging Menu Thunderbird Extension
Low
Unassigned
thunderbird (Ubuntu)
Medium
Chris Coulson

Bug Description

Hi, I have precise, if I start thunderbird, this items start to be in english. See screenshots.

Bilal Akhtar (bilalakhtar) wrote :

Seems like a temporary PO file issue with me.

BTW, you've uploaded the same image twice :)

Changed in indicator-messages:
status: New → Confirmed
importance: Undecided → Medium
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: precise
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what locale do your use? Do the translations work in the software?

Changed in indicator-messages (Ubuntu):
status: Confirmed → Incomplete
Changed in indicator-messages:
status: Confirmed → Incomplete

sorry, about images, now it should be correct.

I use
LC_MESSAGES=sk_SK.UTF-8
LC_COLLATE=sk_SK.UTF-8
LANG=en_GB.UTF-8
LANGUAGE=sk:en

Thunderbird in Slovak language, also unity quicklist is translated, only when I start Thunderbird, Message Menu changes it to english.

Sebastien Bacher (seb128) wrote :

LANG=en_GB.UTF-8 seems wrong, does it happen if you use a correct LANG value?

LANG is for locale, like time format, currency and so, I have changed it to Slovak (logout, log in, checked over printenv) and thunderbird behaved same.

I am in UK, but I use Slovak translations, because I am translator, but I use english locale

Sebastien Bacher (seb128) wrote :

ok, dunno then, indicator-messages didn't change since oneiric and it works here with a french locale so I guess it's an issue somewhere in your locale or tb

can you run command? text in france = "Compose New Message" in france
grep -rs "text in france" /usr/share/locale*

Sebastien Bacher (seb128) wrote :

The translation are stored in the .xpi, the archive one seems translated are you sure you didn't install a local version?

affects: indicator-messages (Ubuntu) → thunderbird (Ubuntu)
Changed in thunderbird (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

ok, seems a bug on the tb side

Changed in thunderbird (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
no longer affects: indicator-messages

Yes, it is in XPI, sorry about this grep. Anyway, I really do not understand, why thunderbird overrides translation in message menu.

Changed in messagingmenu-extension:
importance: Undecided → Low
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

chr1s@farnsworth:~/src/messagingmenu-extension/messagingmenu-extension$ bzr commit -m "Add sk to chrome.manifest" --fixes lp:917920
Committing to: /home/chr1s/src/messagingmenu-extension/messagingmenu-extension/
modified chrome.manifest
Committed revision 107.

Changed in messagingmenu-extension:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 10.0~b4+build1-0ubuntu1

---------------
thunderbird (10.0~b4+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_10_0b4_BUILD1)

  * Update messagingmenu to 0.9.1
    - Fixes LP: #917920 - Messaging menu entries untranslated for Slovak
    - Fixes LP: #917154 - Add Japanese translations
    - Add Spanish translations
    - Don't spawn a new Thunderbird instance when being activated from the
      messaging menu (thus relying on the remoting logic). Instead, use
      the nsIWindowMediator and nsIWindowWatcher interfaces directly
    - Don't keep the main window in the scope of our shared JS module, as
      we're probably going to leak it. Instead, use nsIWindowMediator to
      find the main window when we need it (eg, to switch tabs). Also, use
      nsITimer rather than window.setTimeout().
  * Make it possible to do per-arch patches too
    - update debian/build/enable-dist-patches.pl
    - update debian/rules
    - update debian/patches/series
  * Fix LP: #908508 - Add patch from upstream to fix powerpc build failure.
    Only apply this patch on powerpc to avoid compromising the quality of
    the architectures that we care about
    - add debian/patches/fix-build-failure-without-yarr-jit2.patch
    - update debian/patches/series
  * Also make the previous powerpc build fix apply on ppc only
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Thu, 19 Jan 2012 22:42:09 +0000

Changed in thunderbird (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers