Unity visual glitches and freeze (libgl1-dri-mesa-experimental)

Reported by Lucazade on 2011-01-02
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mesa
New
Undecided
Unassigned
Nouveau Xorg driver
New
Undecided
Unassigned
Unity
Undecided
Unassigned
mesa (Ubuntu)
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

Using Nouveau drivers and libgl1-dri-mesa-experimental package
on a Nvidia 250GTS I get visual artefacts in Unity and a total
freeze of the system (I've to hard reset PC).

Sorry for low quality images but print screen doesn't work!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Sun Jan 2 10:19:28 2011
MachineType: System manufacturer System Product Name
PciDisplay: 02:00.0 VGA compatible controller [0300]: nVidia Corporation G92 [GeForce GTS 250] [10de:0615] (rev a2) (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=it_IT:it:en_GB:en
 LANG=it_IT.UTF-8
 LC_MESSAGES=it_IT.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-11-generic root=UUID=0a53d971-02eb-421b-8e6c-a3b9a0033ad2 ro vt.handoff=7 splash quiet
ProcVersionSignature_: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu6
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 05/07/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1401
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4N78 SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1401:bd05/07/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4N78SE:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-11-generic

Lucazade (lucazade) wrote :
Lucazade (lucazade) wrote :
Alex Launi (alexlauni) wrote :

Does this occur using the proprietary nvidia driver?

Changed in unity (Ubuntu):
status: New → Invalid
status: Invalid → Incomplete
Changed in unity:
status: New → Incomplete
Lucazade (lucazade) wrote :

I get this issue also during gnome-classic session, so it seems not strictly related to Unity.
If I remove libgl1-dri-mesa-experimental the freeze disappear.

I never had this issue with proprietary drivers.

cgarre (cgarre) wrote :

i also see unity freeze atleast once in 1-2 hours. I am now back to classic, and it seems to be fine. when it freezes, i goto another tty and then do a sudo service gdm restart and then log back in.

Omer Akram (om26er) wrote :

I use libgl1-dri-mesa-experimental on nvidia 9800gtx+ and have not seen any visual glitches over the past weeks.

Changed in nouveau:
status: New → Invalid
Lucazade (lucazade) wrote :

Omer I still have this issue... session hangs completely after a few minutes with nouveau drivers,
no problems with proprietary 270.xx drivers.
I have a Nvidia 250gts 1gb and fully updated natty

Changed in nouveau:
status: Invalid → New
Bryce Harrington (bryce) wrote :

[Setting to wishlist since -experimental is not yet officially supported in Ubuntu.]

This bug should probably be filed to upstream mesa.

Changed in mesa (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Yumi (tempreg) wrote :

Partial freezes here with classic desktop. However only the program freezes with no CPU activity recorded. Am able to end the running program through system monitor and then restart the program without hard reset the computer.

Omer Akram (om26er) on 2011-06-18
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Bryce Harrington (bryce) wrote :

Hey lucazade,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers