Please show -proposed package version information on merges.u.c

Bug #1518113 reported by Steve Langasek on 2015-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Merge-o-Matic
Medium
Brian Murray

Bug Description

With the introduction of -proposed, the information on merges.ubuntu.com is sometimes out of date, because an updated package can be stalled in -proposed for an indeterminate amount of time. This can result in duplicated effort, if someone starts working on a merge without separately checking whether there is an updated package in -proposed.

I think merges.u.c should:
 - display the version of the package in -proposed, if any
 - change the display of (gray out?) those rows that have a version in -proposed newer than the version in Debian.

Related branches

Steve Langasek (vorlon) on 2015-11-19
Changed in merge-o-matic:
assignee: nobody → Brian Murray (brian-murray)
Artur Rona (ari-tczew) wrote :

I guess this one is a duplicate of bug #1202142.

Steve Langasek (vorlon) wrote :

No, that bug asks for proposed to be used as the merge base. I'm only asking for visibility on proposed.

Brian Murray (brian-murray) wrote :

I've added a function to momlib to check and see if there is a newer package version in -proposed.

$ bzr commit -m "momlib.py: add in function to see if there is a package in -proposed greater than the Ubuntu version."
Committing to: /home/bdmurray/source-trees/merge-o-matic/trunk/
modified momlib.py
Committed revision 253.

Just need to fix the html output now.

Changed in merge-o-matic:
status: New → In Progress
importance: Undecided → Medium
Changed in merge-o-matic:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers