PyGIWarning: GMenu was imported without specifying a version first.

Bug #1529406 reported by fredda on 2015-12-26
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
MenuLibre
Undecided
Unassigned

Bug Description

I tried to start menulibre from terminal because of the segfault from menu.
And this is the output i've got.

menulibre
sys:1: PyGIWarning: GMenu was imported without specifying a version first. Use gi.require_version('GMenu', '3.0') before import to ensure that the right version gets loaded.
No menu prefix found, MenuLibre will not function properly.
WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/menulibre/MenulibreApplication.py", line 1717, in do_activate
    self.win = MenulibreWindow(self)
  File "/usr/lib/python3.5/site-packages/menulibre/MenulibreApplication.py", line 207, in __init__
    self.configure_application_treeview(builder)
  File "/usr/lib/python3.5/site-packages/menulibre/MenulibreApplication.py", line 462, in configure_application_treeview
    self.treeview = MenulibreTreeview.Treeview(self, builder)
  File "/usr/lib/python3.5/site-packages/menulibre/MenulibreTreeview.py", line 43, in __init__
    self._configure_treeview(builder)
  File "/usr/lib/python3.5/site-packages/menulibre/MenulibreTreeview.py", line 54, in _configure_treeview
    treestore = MenuEditor.get_treestore()
  File "/usr/lib/python3.5/site-packages/menulibre/MenuEditor.py", line 113, in get_treestore
    menu = get_menus()[0]
  File "/usr/lib/python3.5/site-packages/menulibre/MenuEditor.py", line 175, in get_menus
    menu = MenuEditor()
  File "/usr/lib/python3.5/site-packages/menulibre/MenuEditor.py", line 227, in __init__
    self.load()
  File "/usr/lib/python3.5/site-packages/menulibre/MenuEditor.py", line 245, in load
    if not self.tree.load_sync():
GLib.Error: g-io-error-quark: Failed to look up menu_file for "applications.menu"
 (0)

I use arch linux and latest menulibre.
thanks

Sean Davis (bluesabre) wrote :

It looks like you may not have the XDG_MENU_PREFIX environment variable set. What desktop environment are you using?

fredda (fredda-71) wrote :

Hello Sean.
I completely forgot this bugreport.
When the bug happens i used mate-gtk3 experimental in arch linux .
I switched to xfce4 last week and are not affected by this problem anymore.

Thanks
freddie

Omadas (bsperger) wrote :

I am now affected by this bug just upgraded to Linux Mint 18. How do I correctly set XDG_MENU_PREFIX?

Iamanan Emmanuel (iamanel) wrote :

I get the following with Ubuntu-MATE 17.10 beta2:

iamanan@Vostro5470:~$ menulibre
/usr/lib/python3/dist-packages/menulibre/MenuEditor.py:28: PyGIWarning: GMenu was imported without specifying a version first. Use gi.require_version('GMenu', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkPixbuf, Gio, GLib, GMenu, Gtk
No menu prefix found, MenuLibre will not function properly.
WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'
WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'
WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'

Changed in menulibre:
status: New → Confirmed
Sean Davis (bluesabre) wrote :
Changed in menulibre:
status: Confirmed → Fix Committed
Sean Davis (bluesabre) on 2018-02-05
Changed in menulibre:
milestone: none → 2.1.5
Sean Davis (bluesabre) on 2018-02-05
Changed in menulibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers