Crashes due to change in psutil

Bug #1474484 reported by Frogman on 2015-07-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MenuLibre
Undecided
Sean Davis

Bug Description

Here's my post from Manjaro (Arch-based distro) forum:

Menu Editor (MenuLibre) stopped working - Solved

After a recent update, I noticed that the Menu Editor stopped working. Running "menulibre" from a terminal command line showed the error:

[code] File "/usr/lib/python3.4/site-packages/menulibre/util.py", line 78, in getProcessList
    for pid in psutil.get_pid_list():
AttributeError: 'module' object has no attribute 'get_pid_list'[/code]

I checked the Package Manager for "psutil" and found "python-psutil" was installed. Going to the included link [url]https://github.com/giampaolo/psutil[/url] and searching for "get_pid_list()" showed

[code] | Old name | Replacement |
  +==========================+===============================+
  | - psutil.get_pid_list() | psutil.pids() |[/code]

I went to "/usr/lib/python3.4/site-packages/menulibre/util.py" and changed "get_pid_list()" to "pids()" on line 78, and voila! the Menu Editor worked again.

I'm posting this in hopes it may save other others some aggravation.

Frogman (jporubek) on 2015-07-14
no longer affects: menulibre (Arch Linux)
Sean Davis (bluesabre) wrote :

Thanks for the bug report and research. Applied to the 2.0 and 2.1 branches and will be in the next set of releases.

2.0.x: https://bazaar.launchpad.net/~menulibre-dev/menulibre/master/revision/285
2.1.x: https://bazaar.launchpad.net/~menulibre-dev/menulibre/2.1/revision/257

Changed in menulibre:
status: New → Fix Committed
Frogman (jporubek) wrote :

You're welcome. Thank you for creating and maintaining a great tool!

Sean Davis (bluesabre) on 2015-08-09
Changed in menulibre:
milestone: none → 2.0.1
milestone: 2.0.1 → 2.0.7
status: Fix Committed → Fix Released
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints