Unable to edit(copy) desktop files with periods in the filename.

Bug #1430613 reported by Michael Heyns on 2015-03-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MenuLibre
Undecided
Sean Davis

Bug Description

I am an Arch Linux user and I have not checked this issue on another distro.

Saving changes when editing a desktop entry with a period/fullstop in its filename is disabled. I've noticed this with some commercial software and many GNOME applications recently too, i.e. org.gnome.Nautilus.desktop; org.gnome.Totem.desktop; org.gnome.FileRoller.desktop, etc. etc.

Terminal output:

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/menulibre/MenulibreApplication.py", line 1437, in on_treeview_cursor_changed
    self.set_value(key, entry[key], store=True)
  File "/usr/lib/python3.4/site-packages/menulibre/MenulibreApplication.py", line 1905, in set_value
    widget.set_text(value)
TypeError: Must be string, not bool

Sean Davis (bluesabre) wrote :

Which version of MenuLibre are you running? I cannot seem to reproduce this bug.

Sean Davis (bluesabre) wrote :

Correction, was able to reproduce on Fedora 22. Looking into it...

Changed in menulibre:
status: New → Confirmed
Sean Davis (bluesabre) wrote :

It turns out, the issue is that several Gnome apps use the boolean fields in the Advanced section (not very common). Menulibre was incorrectly trying to put the boolean values in the entry text field. Fixed in the 2.0 and 2.1 branches.

2.0.x: https://bazaar.launchpad.net/~menulibre-dev/menulibre/master/revision/286
2.1.x: https://bazaar.launchpad.net/~menulibre-dev/menulibre/2.1/revision/258

Changed in menulibre:
status: Confirmed → Fix Committed
Sean Davis (bluesabre) on 2015-08-09
Changed in menulibre:
milestone: none → 2.0.7
status: Fix Committed → Fix Released
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints