move items up & down, can't save, undo/redo, revert

Bug #1313586 reported by Garry Trethewey on 2014-04-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MenuLibre
Medium
Unassigned
menulibre (Ubuntu)
Undecided
Unassigned

Bug Description

New install xubuntu 14.04, plus lots of gnome & kde stuff - eg kwrite, libre office, alacarte etc

In menulibre (alacarte not running) , I move items up & down using the arrows, but the buttons for save, undo/redo, revert don't light up, so I can't save, undo/redo, revert, and when I leave that sub-menu, I don't get asked it I'd like to save.

Making new items saves OK.

Important to me. eg As various editors get installed, they end up in various places. I like to make a category like eg Editors, to put several editors in. But can't.

Happy to provide more info if req.

regards Garry

Related branches

Sean Davis (bluesabre) wrote :

Hi Garry,

Menu changes such as moving take place immediately. Any other changes should be available from the Add menu, which allows you to create new directories, launchers, and separators. These can be modified with a full history and deleted as well.

Garry Trethewey (garrytreth) wrote :

"Menu changes such as moving take place immediately. "

But not what you want.

I select Office/Gnumeric and use up arrow to move Office/Gnumeric up to Multimedia.

Result in the menu:-
Gnumeric has moved down to the bottom of Office. Gnumeric is not in Multimedia.

Maybe relevant, I've "complete uninstall" both menulibre & alacarte. Then new install menulibre. It doesn't show up in the menu, so I terminal/menulibre.

garry@xfce14-04:~$ menulibre

(menulibre:3646): Gtk-CRITICAL **: gtk_tree_model_get_iter: assertion 'path->depth > 0' failed

Sean Davis (bluesabre) wrote :

I've determined that this is probably an issue in the code. When you move an application to another category, can you try to toggle one of the switches on and off, and then re-save the launcher? Let me know if that correctly moves the launcher.

Changed in menulibre:
status: New → Triaged
importance: Undecided → Medium
Sean Davis (bluesabre) wrote :

I've now fixed this in trunk. The next release will change the categories when launchers are moved. Thanks for your bug report!

Changed in menulibre:
status: Triaged → Fix Committed
Garry Trethewey (garrytreth) wrote :

Thanks for your work.

Sean Davis (bluesabre) on 2014-05-14
Changed in menulibre:
milestone: none → 2.0.4
Sean Davis (bluesabre) on 2014-05-14
Changed in menulibre:
status: Fix Committed → Fix Released

Hello Garry, or anyone else affected,

Accepted menulibre into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/menulibre/2.0.4-1~ubuntu14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jack Fromm (jjfrv8) wrote :

According to Sean, moving an existing launcher to another location or directory does not require a Save. The change takes place immediately. Confirmed in 2.04 by exiting and re-launching Menulibre.

tags: added: verification-done
removed: down error save up verification-needed
Garry Trethewey (garrytreth) wrote :
Download full text (3.3 KiB)

menulibre 2.0.4-1 trusty
xubuntu trusty

terms:-
ml = menulibre
am = actual menu

Executive Summary.
Seems to me, if you have a non-default menu that was set up by alacarte, any pre-existing non-default menu categories (made by alacarte) _might_ have their launchers deleted as soon as ml saves anything. So then as can be expected, the empty categories don't show up on am. This happened on one trial, not another. If it doesn't, there's a possibility of a work around to save your categories & launchers.

For people who haven't got a pre-existing non-default menu, but want to start modifying their menu from scratch, things work better than when Trusty came out, making ml viable for people who haven't used alacarte.

Non-default categories & launchers created by ml persist between closing & opening ml.

Launchers moved into the non-default categories make that category appear in am.

Things moved about or created by ml seem to show up in am and stick without having to toggle any of the on-off options.

So for me, it looks like if I install ml it will trash my existing am (created by alacarte), but at least if I then re-create that menu system, it will be a bit easier, and will stick.

Run 1

existing categories include non-standard map, editors, places

map, qgis desktop , up into Graphics, Use Startup Notification on, off to get “save launcher” active, (which I read later isn't now necessary) click “save launcher”
→ actual menu reverted to no instance of map or editors or my other home-made categories.
===> fail

graphics, document viewer, up into Games, Use Startup Notification off, on to enable save, save.
→ actual menu contains Games, Document Viewer.
===> pass

Close all categories (don't show launchers)
+ , Add directory, → new directory.
Rename that to Dummy01, save. → now have category called Dummy01, selected.
+ Add launcher → new launcher
Command = kwrite , top name = kwrite, save
===> pass

Restore my menu system.
existing categories include map, editors, places
Run 2

Start menulibre
→ my menu still exists

Select games (a default category)
→ my menu still exists
+, Add launcher,
→ my menu still exists
top name = kwritezzz, command kwrite, save
→ my am disappeared, reverted to default
===> fail

Restore my menu system.
existing categories include map, editors, places
Run 3
Save something in ml
→ all my map launchers and my editor launchers disappeared in am.
But they persist in ml. (didn't last run, dunno why)
Trying not to loose them, so in ml I select a launcher, toggle an option on, off
→ save lights up, so I save
→ the big window bottom right suddenly goes from blank to Category name = menulibre-map, Description = menulibre-map, and that launcher shows up on am.

Repeat with other launchers in other categories.

But you have to do it with all categories & launchers that you want to save before you close ml, because when you re-open, the ones you didn't process are gone.

#Note to self. To revert from testing:-
delete ml from synaptic
Software sources – untick proposed
disable apport “crash” as in
https://wiki.ubuntu.com/Testing/EnableProposed
restore old menu
~/.config/menus # not ~/c...

Read more...

Sean Davis (bluesabre) wrote :

Hi Garry, I think what you described above would be considered a separate issue. Would you mind creating a new bug "Menulibre does not import alacarte-mate categories" and attaching your existing menu files?

The verification of the Stable Release Update for menulibre has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Garry Trethewey (garrytreth) wrote :

ok will do

Changed in menulibre (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers