Memory Leak in Live Stats

Bug #353329 reported by Nick Verbeck on 2009-04-01
2
Affects Status Importance Assigned to Milestone
Memcached Manager
Critical
Nick Verbeck

Bug Description

Memory Leak in Live Stats Monitor when left running. The memory consumption for the whole app continues to grow at a steady rate.

Possible location may be in the sample storage array.

Nick Verbeck (nerdynick) on 2009-04-01
Changed in memcached-manager:
assignee: nobody → nerdynick
importance: Undecided → Critical
milestone: none → 0.1
status: New → Confirmed
Nick Verbeck (nerdynick) wrote :

Upon some simple investigation it turns out to be a memory leak somewhere in Matplotlib. When starting to draw a figure matplotlib appears to not wish to clear out its memory foot print. In finding this out it appears this would be a bug in the normal stats graphs as well.

Nick Verbeck (nerdynick) wrote :

Live Stats no longer uses matplotlib. No more mem leak now.

Changed in memcached-manager:
status: Confirmed → Fix Committed
Nick Verbeck (nerdynick) on 2010-12-06
Changed in memcached-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers